CBPRS.Parking

City Based Parking and Routing System API Documentation

CBPRS.Parking Namespace

CBPRS.Parking contains the parking service of the CBPRS and provides parking places, parking garages, parking vehilces and a parking system.

Namespace hierarchy

Classes

Class | Description
AdminSystem | The main administrative system of the parking system infrastructure.
AntParkingVehicle | Vehicle that uses the CBPRS system to drive to its parking place.
Bus | Vehicle that uses the Dijkstra algorithm for routing but also provides delay information to the ant algorithm.
BusStop | A bus stop.
DijkstraParkingVehicle | Default Dijkstra vehicle for parking.
LampPost | The lamppost
ParkingGarage | Parking garage that stores multiple parked vehicles
ParkingPlace | Class that represents a road side parking place
ParkingSlot | A parking slot that allows a vehicle to be parked for a certain period.
ParkingSystem | The parking system (facade)
ParkingSystemSurrogate | Surrogate class for ParkingSystem de- / serialization.
SectorStation | Default sector station for the simulation environment.

Interfaces

Interface | Description
IParking | Default interface for a parking.

Enumerations

Enumeration | Description
ParkingPlaceStatus | Enumeration of the different states a parking place can have.

(c) 2006 - 2007 J.L.Boehlé. All Rights Reserved.


AdminSystem Class

The main administrative system of the parking system infrastructure.

For a list of all members of this type, see AdminSystem Members.

System.Object
CBPRS.Parking.AdminSystem

public class AdminSystem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

AdminSystem Members | CBPRS.Parking Namespace


AdminSystem Members

AdminSystem overview

Public Static Properties

ParkingHourSlots | Gets the maximum hour slots in the administration system.
ParkingHourSlotsPerHour | The number of parking slots per hour.

Protected Static Fields

cMaxParkingHourSlots | The maximum number of hours that a vehicle can reserve a parking place.
cMaxParkingSlotsPerHour | The slot per hour limiting the time a place can be reserved.
cSecondsPerHour | The number of seconds per hour.

Public Instance Constructors

AdminSystem Constructor Default constructor

Public Instance Properties

MaxParkingTime Gets the maximum time a vehicle is allowed to parked.

Public Instance Methods

AddVehicleSlot | Creates a vehicle parking slot.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParkingSlot | Gets the parking slot at the specified hour and slot.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Resets the parking system by cleaning all parking slots.
Simulate | Simulates the parking system thus allowing vehicles to exit.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Parking The list of all parked vehicles in the simulation.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem Constructor

Default constructor

public AdminSystem();

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem Fields

The fields of the AdminSystem class are listed below. For a complete list of AdminSystem class members, see the AdminSystem Members topic.

Protected Static Fields

cMaxParkingHourSlots | The maximum number of hours that a vehicle can reserve a parking place.
cMaxParkingSlotsPerHour | The slot per hour limiting the time a place can be reserved.
cSecondsPerHour | The number of seconds per hour.

Protected Instance Fields

_Parking The list of all parked vehicles in the simulation.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem._Parking Field

The list of all parked vehicles in the simulation.

protected 0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] _Parking;

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.cMaxParkingHourSlots Field

The maximum number of hours that a vehicle can reserve a parking place.

protected static int cMaxParkingHourSlots;

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.cMaxParkingSlotsPerHour Field

The slot per hour limiting the time a place can be reserved.

protected static int cMaxParkingSlotsPerHour;

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.cSecondsPerHour Field

The number of seconds per hour.

protected const int cSecondsPerHour = 3600;

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem Properties

The properties of the AdminSystem class are listed below. For a complete list of AdminSystem class members, see the AdminSystem Members topic.

Public Static Properties

ParkingHourSlots | Gets the maximum hour slots in the administration system.
ParkingHourSlotsPerHour | The number of parking slots per hour.

Public Instance Properties

MaxParkingTime Gets the maximum time a vehicle is allowed to parked.

See Also

AdminSystem Class | CBPRS.Parking Namespace


MaxParkingTime Property

City Based Parking and Routing System API Documentation

AdminSystem.MaxParkingTime Property

Gets the maximum time a vehicle is allowed to parked.

public int MaxParkingTime {get;}

See Also

AdminSystem Class | CBPRS.Parking Namespace


ParkingHourSlots Property

City Based Parking and Routing System API Documentation

AdminSystem.ParkingHourSlots Property

Gets the maximum hour slots in the administration system.

public static int ParkingHourSlots {get; set;}

Remarks

This value restricts the maximum availible time to reserve a parking place.

See Also

AdminSystem Class | CBPRS.Parking Namespace


ParkingHourSlotsPerHour Property

City Based Parking and Routing System API Documentation

AdminSystem.ParkingHourSlotsPerHour Property

The number of parking slots per hour.

public static int ParkingHourSlotsPerHour {get; set;}

Remarks

This value groups time request together that fall in certain category.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem Methods

The methods of the AdminSystem class are listed below. For a complete list of AdminSystem class members, see the AdminSystem Members topic.

Public Instance Methods

AddVehicleSlot | Creates a vehicle parking slot.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetParkingSlot | Gets the parking slot at the specified hour and slot.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Resets the parking system by cleaning all parking slots.
Simulate | Simulates the parking system thus allowing vehicles to exit.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.AddVehicleSlot Method

Creates a vehicle parking slot.

public void AddVehicleSlot(
IVehicle vehicle,
IParking parking,
uint time
);

Parameters

vehicle
The vehicle that is parking.
parking
The place at which the vehicle is parked.
time
The time in simulation step the vehicle remains parked there.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.GetParkingSlot Method

Gets the parking slot at the specified hour and slot.

public 0, Culture=neutral, PublicKeyToken=null]] GetParkingSlot(
uint hour,
uint slot
);

Parameters

hour
The hour
slot
The parking slot.

Return Value

The requested parking slot.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.Reset Method

Resets the parking system by cleaning all parking slots.

public void Reset();

See Also

AdminSystem Class | CBPRS.Parking Namespace


AdminSystem.Simulate Method

Simulates the parking system thus allowing vehicles to exit.

public void Simulate(
uint step
);

Parameters

step
The current time step.

See Also

AdminSystem Class | CBPRS.Parking Namespace


AntParkingVehicle Class

Vehicle that uses the CBPRS system to drive to its parking place.

For a list of all members of this type, see AntParkingVehicle Members.

System.Object
CBPRS.Infrastructure.Vehicle
CBPRS.Parking.AntParkingVehicle

public class AntParkingVehicle : Vehicle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

AntParkingVehicle Members | CBPRS.Parking Namespace


AntParkingVehicle Members

AntParkingVehicle overview

Public Static Methods

Create The vehicle creation factory method.

Protected Static Fields

cTimeRequiredToTurn | The period of time consumed while turning on the road.
cVehicleParkInTime | The time - in simulation steps - required to park the vehicle.

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the vehicle in blocks.
MaxSpeed | Gets the maximum speed of the vehicle in blocks per step.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateRoutingSystem | Gets or sets a boolean value indicating that the vehicle should update the routing system with delay information.

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initialize the routing for the current vehicle.
Move | Moves the vehicle on step forward.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
RevertVehicleRoute | Reverts the route of the vehicle.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the current route.

Protected Instance Constructors

AntParkingVehicle Constructor Default constructor

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_POnOtherLane | boolean that indicates if the parking place is on the other lane of the current road.
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TimeToParkVehicle | The time - in simulation steps - required to park the vehicle.
_UpdateRouting | Boolean indicating if the routing system is updated by this vehicle.

Protected Instance Methods

ExecuteOtherLaneParkingProcedure | Executes the parking procedure by moving the vehicle towards the parking place and then changing lanes.
ExecuteParkingProcedure | Moves the vehicle towards the parking place on the desired lane is reached.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateRouting | Updates the routing system by transmitting delays.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle Constructor

Default constructor

protected AntParkingVehicle(
int id
);

Parameters

id
The id to be assigned to the vehicle.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle Fields

The fields of the AntParkingVehicle class are listed below. For a complete list of AntParkingVehicle class members, see the AntParkingVehicle Members topic.

Protected Static Fields

cTimeRequiredToTurn | The period of time consumed while turning on the road.
cVehicleParkInTime | The time - in simulation steps - required to park the vehicle.

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_POnOtherLane | boolean that indicates if the parking place is on the other lane of the current road.
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TimeToParkVehicle | The time - in simulation steps - required to park the vehicle.
_UpdateRouting | Boolean indicating if the routing system is updated by this vehicle.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle._POnOtherLane Field

boolean that indicates if the parking place is on the other lane of the current road.

protected bool _POnOtherLane;

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle._TimeToParkVehicle Field

The time - in simulation steps - required to park the vehicle.

protected int _TimeToParkVehicle;

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle._UpdateRouting Field

Boolean indicating if the routing system is updated by this vehicle.

protected bool _UpdateRouting;

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.cTimeRequiredToTurn Field

The period of time consumed while turning on the road.

protected const int cTimeRequiredToTurn = 10;

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.cVehicleParkInTime Field

The time - in simulation steps - required to park the vehicle.

protected const int cVehicleParkInTime = 5;

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle Properties

The properties of the AntParkingVehicle class are listed below. For a complete list of AntParkingVehicle class members, see the AntParkingVehicle Members topic.

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the vehicle in blocks.
MaxSpeed | Gets the maximum speed of the vehicle in blocks per step.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateRoutingSystem | Gets or sets a boolean value indicating that the vehicle should update the routing system with delay information.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


Length Property

City Based Parking and Routing System API Documentation

AntParkingVehicle.Length Property

Gets the length of the vehicle in blocks.

public override int Length {get;}

Implements

IVehicle.Length

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


MaxSpeed Property

City Based Parking and Routing System API Documentation

AntParkingVehicle.MaxSpeed Property

Gets the maximum speed of the vehicle in blocks per step.

public override int MaxSpeed {get;}

Implements

IVehicle.MaxSpeed

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


UpdateRoutingSystem Property

City Based Parking and Routing System API Documentation

AntParkingVehicle.UpdateRoutingSystem Property

Gets or sets a boolean value indicating that the vehicle should update the routing system with delay information.

public bool UpdateRoutingSystem {get; set;}

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle Methods

The methods of the AntParkingVehicle class are listed below. For a complete list of AntParkingVehicle class members, see the AntParkingVehicle Members topic.

Public Static Methods

Create The vehicle creation factory method.

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initialize the routing for the current vehicle.
Move | Moves the vehicle on step forward.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
RevertVehicleRoute | Reverts the route of the vehicle.
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the current route.

Protected Instance Methods

ExecuteOtherLaneParkingProcedure | Executes the parking procedure by moving the vehicle towards the parking place and then changing lanes.
ExecuteParkingProcedure | Moves the vehicle towards the parking place on the desired lane is reached.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateRouting | Updates the routing system by transmitting delays.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.Create Method

The vehicle creation factory method.

public static IVehicle Create(
int id
);

Parameters

id
The id to be assigned to the vehicle.

Return Value

A newly created AntVehicle with the specified id assigned.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.ExecuteOtherLaneParkingProcedure Method

Executes the parking procedure by moving the vehicle towards the parking place and then changing lanes.

protected void ExecuteOtherLaneParkingProcedure(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of the current.
step
The current simulation step.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.ExecuteParkingProcedure Method

Moves the vehicle towards the parking place on the desired lane is reached.

protected void ExecuteParkingProcedure(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of the current.
step
The current simulation step.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.IntializeRoute Method

Initialize the routing for the current vehicle.

public override void IntializeRoute(
IIntersection source,
uint step
);

Parameters

source
The generator at which the vehicle was generated.
step
The current time step.

Implements

IVehicle.IntializeRoute

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.Move Method

Moves the vehicle on step forward.

public override void Move(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of the current, or null if none present.
step
The current simulation time step.

Implements

IVehicle.Move

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.RevertVehicleRoute Method

Reverts the route of the vehicle.

public void RevertVehicleRoute(
uint step
);

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.UpdateRoute Method

Updates the current route.

public override void UpdateRoute(
uint step
);

Parameters

step
The current time step

Implements

IVehicle.UpdateRoute

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


AntParkingVehicle.UpdateRouting Method

Updates the routing system by transmitting delays.

protected void UpdateRouting(
AntRoute route,
int Delay
);

Parameters

route
The route followed by the vehicle.
Delay
The delay experienced on the route.

See Also

AntParkingVehicle Class | CBPRS.Parking Namespace


Bus Class

Vehicle that uses the Dijkstra algorithm for routing but also provides delay information to the ant algorithm.

For a list of all members of this type, see Bus Members.

System.Object
CBPRS.Infrastructure.Vehicle
CBPRS.Parking.Bus

public class Bus : Vehicle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

Bus Members | CBPRS.Parking Namespace


Bus Members

Bus overview

Public Static Methods

Create The factory creation method.

Protected Static Fields

cBusLength | The length of the bus in blocks
cBusMaxSpeed | The maximum speed of the bus
cBusStopWaitingTime | The default time a bus waits at a bus stop.

Public Instance Constructors

Bus Constructor Default constructor

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
BusRoute | Gets or sets the Bus route for the bus to follow.
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the current vehicle.
MaxSpeed | Gets the maximum speed at which this vehicle can travel.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initialize the route.
Move | Moves the vehicle along the drive lanes.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the route of the vehicle by consulting the Dijkstra routing tables.

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_BusRoute | The bus route along which the bus travels.
_BusRouteId | The Id number of the current BusRoute.
_BusStopStoppageTime | The time the bus waits at each bus stop.
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_Previous | The previous lane for ant algorithm delay updating.
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TimeToWait | The time the bus is required to wait a the current position.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
RouteToNextBusstop | Finds the next bus stop on the route and updates the routing.
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateLinkDelay | Updates the registered delay for the current link.

See Also

Bus Class | CBPRS.Parking Namespace


Bus Constructor

Default constructor

public Bus(
int id
);

Parameters

id
The id to be assigned to the vehicle

See Also

Bus Class | CBPRS.Parking Namespace


Bus Fields

The fields of the Bus class are listed below. For a complete list of Bus class members, see the Bus Members topic.

Protected Static Fields

cBusLength | The length of the bus in blocks
cBusMaxSpeed | The maximum speed of the bus
cBusStopWaitingTime | The default time a bus waits at a bus stop.

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_BusRoute | The bus route along which the bus travels.
_BusRouteId | The Id number of the current BusRoute.
_BusStopStoppageTime | The time the bus waits at each bus stop.
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_Previous | The previous lane for ant algorithm delay updating.
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TimeToWait | The time the bus is required to wait a the current position.

See Also

Bus Class | CBPRS.Parking Namespace


Bus._BusRoute Field

The bus route along which the bus travels.

protected 0, Culture=neutral, PublicKeyToken=null]] _BusRoute;

See Also

Bus Class | CBPRS.Parking Namespace


Bus._BusRouteId Field

The Id number of the current BusRoute.

protected int _BusRouteId;

See Also

Bus Class | CBPRS.Parking Namespace


Bus._BusStopStoppageTime Field

The time the bus waits at each bus stop.

protected int _BusStopStoppageTime;

See Also

Bus Class | CBPRS.Parking Namespace


Bus._Previous Field

The previous lane for ant algorithm delay updating.

protected ILane _Previous;

See Also

Bus Class | CBPRS.Parking Namespace


Bus._TimeToWait Field

The time the bus is required to wait a the current position.

protected int _TimeToWait;

See Also

Bus Class | CBPRS.Parking Namespace


Bus.cBusLength Field

The length of the bus in blocks

protected const int cBusLength = 2;

See Also

Bus Class | CBPRS.Parking Namespace


Bus.cBusMaxSpeed Field

The maximum speed of the bus

protected const int cBusMaxSpeed = 4;

See Also

Bus Class | CBPRS.Parking Namespace


Bus.cBusStopWaitingTime Field

The default time a bus waits at a bus stop.

protected const int cBusStopWaitingTime = 15;

See Also

Bus Class | CBPRS.Parking Namespace


Bus Properties

The properties of the Bus class are listed below. For a complete list of Bus class members, see the Bus Members topic.

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
BusRoute | Gets or sets the Bus route for the bus to follow.
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the current vehicle.
MaxSpeed | Gets the maximum speed at which this vehicle can travel.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |

See Also

Bus Class | CBPRS.Parking Namespace


BusRoute Property

City Based Parking and Routing System API Documentation

Bus.BusRoute Property

Gets or sets the Bus route for the bus to follow.

public int BusRoute {get; set;}

See Also

Bus Class | CBPRS.Parking Namespace


Length Property

City Based Parking and Routing System API Documentation

Bus.Length Property

Gets the length of the current vehicle.

public override int Length {get;}

Implements

IVehicle.Length

See Also

Bus Class | CBPRS.Parking Namespace


MaxSpeed Property

City Based Parking and Routing System API Documentation

Bus.MaxSpeed Property

Gets the maximum speed at which this vehicle can travel.

public override int MaxSpeed {get;}

Implements

IVehicle.MaxSpeed

See Also

Bus Class | CBPRS.Parking Namespace


Bus Methods

The methods of the Bus class are listed below. For a complete list of Bus class members, see the Bus Members topic.

Public Static Methods

Create The factory creation method.

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initialize the route.
Move | Moves the vehicle along the drive lanes.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the route of the vehicle by consulting the Dijkstra routing tables.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
RouteToNextBusstop | Finds the next bus stop on the route and updates the routing.
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |
UpdateLinkDelay | Updates the registered delay for the current link.

See Also

Bus Class | CBPRS.Parking Namespace


Bus.Create Method

The factory creation method.

public static IVehicle Create(
int id
);

Parameters

id
The id for the newly create vehicle.

Return Value

A newly created Bus with the specified id assigned.

See Also

Bus Class | CBPRS.Parking Namespace


Bus.IntializeRoute Method

Initialize the route.

public override void IntializeRoute(
IIntersection source,
uint step
);

Parameters

source
The source intersection of the vehicle.
step
The current time step.

Implements

IVehicle.IntializeRoute

See Also

Bus Class | CBPRS.Parking Namespace


Bus.Move Method

Moves the vehicle along the drive lanes.

public override void Move(
IVehicle vfront,
uint step
);

Parameters

vfront
The IVehicle directly in front of the current.
step
The current time step.

Implements

IVehicle.Move

See Also

Bus Class | CBPRS.Parking Namespace


Bus.RouteToNextBusstop Method

Finds the next bus stop on the route and updates the routing.

protected void RouteToNextBusstop();

See Also

Bus Class | CBPRS.Parking Namespace


Bus.UpdateLinkDelay Method

Updates the registered delay for the current link.

protected void UpdateLinkDelay(
int Delay
);

See Also

Bus Class | CBPRS.Parking Namespace


Bus.UpdateRoute Method

Updates the route of the vehicle by consulting the Dijkstra routing tables.

public override void UpdateRoute(
uint step
);

Parameters

step
The current time step.

Implements

IVehicle.UpdateRoute

Remarks

This function is called after the intersection has entered a new lane (i.e. is crossing the intersection). This function further assumes that DijkstraVehicles as implemented in the routing subsystem travel from generator to generator therefore once the destination is reached we do not update the route anymore but let the vehicle be consumed by the exit.

See Also

Bus Class | CBPRS.Parking Namespace


BusStop Class

A bus stop.

For a list of all members of this type, see BusStop Members.

System.Object
CBPRS.Parking.BusStop

public class BusStop : ISideObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

BusStop Members | CBPRS.Parking Namespace


BusStop Members

BusStop overview

Protected Static Fields

cStoppageTime The default time that a bus stops at a bus stop.

Public Instance Constructors

BusStop Constructor Default constructor

Public Instance Properties

BusRouteId | Gets or sets the bus route id to which this bus stop belongs
Cell | The cell at which this bus stop can be entered.
FillCell | Gets a boolean indicating if the cell should be filled.
Indicator | Gets the bus stop legend
Lane | Gets or sets the alongside which this bus stop is.
SideColor | The color to fill the cell with.
StoppageTime | Gets or sets the stoppage time for buses.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_BusRouteId | The route id of which this bus stop is part.
_Cell | The cells occupied by this bus stop.
_Lane | The lane which is adjacent to this bus stop.
_StoppageTime | The period of time that a bus should stop here.
_Vehicle | The bus currently waiting at the space.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop Constructor

Default constructor

public BusStop();

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop Fields

The fields of the BusStop class are listed below. For a complete list of BusStop class members, see the BusStop Members topic.

Protected Static Fields

cStoppageTime The default time that a bus stops at a bus stop.

Protected Instance Fields

_BusRouteId | The route id of which this bus stop is part.
_Cell | The cells occupied by this bus stop.
_Lane | The lane which is adjacent to this bus stop.
_StoppageTime | The period of time that a bus should stop here.
_Vehicle | The bus currently waiting at the space.

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop._BusRouteId Field

The route id of which this bus stop is part.

protected int _BusRouteId;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop._Cell Field

The cells occupied by this bus stop.

protected int _Cell;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop._Lane Field

The lane which is adjacent to this bus stop.

protected ILane _Lane;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop._StoppageTime Field

The period of time that a bus should stop here.

protected int _StoppageTime;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop._Vehicle Field

The bus currently waiting at the space.

protected IVehicle _Vehicle;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop.cStoppageTime Field

The default time that a bus stops at a bus stop.

protected static int cStoppageTime;

See Also

BusStop Class | CBPRS.Parking Namespace


BusStop Properties

The properties of the BusStop class are listed below. For a complete list of BusStop class members, see the BusStop Members topic.

Public Instance Properties

BusRouteId | Gets or sets the bus route id to which this bus stop belongs
Cell | The cell at which this bus stop can be entered.
FillCell | Gets a boolean indicating if the cell should be filled.
Indicator | Gets the bus stop legend
Lane | Gets or sets the alongside which this bus stop is.
SideColor | The color to fill the cell with.
StoppageTime | Gets or sets the stoppage time for buses.

See Also

BusStop Class | CBPRS.Parking Namespace


BusRouteId Property

City Based Parking and Routing System API Documentation

BusStop.BusRouteId Property

Gets or sets the bus route id to which this bus stop belongs

public int BusRouteId {get; set;}

See Also

BusStop Class | CBPRS.Parking Namespace


Cell Property

City Based Parking and Routing System API Documentation

BusStop.Cell Property

The cell at which this bus stop can be entered.

public int Cell {get; set;}

Implements

ISideObject.Cell

See Also

BusStop Class | CBPRS.Parking Namespace


FillCell Property

City Based Parking and Routing System API Documentation

BusStop.FillCell Property

Gets a boolean indicating if the cell should be filled.

public bool FillCell {get;}

Implements

ISideObject.FillCell

See Also

BusStop Class | CBPRS.Parking Namespace


Indicator Property

City Based Parking and Routing System API Documentation

BusStop.Indicator Property

Gets the bus stop legend

public string Indicator {get;}

Implements

ISideObject.Indicator

See Also

BusStop Class | CBPRS.Parking Namespace


Lane Property

City Based Parking and Routing System API Documentation

BusStop.Lane Property

Gets or sets the alongside which this bus stop is.

public CBPRS.Infrastructure.ILane Lane {get; set;}

Implements

ISideObject.Lane

See Also

BusStop Class | CBPRS.Parking Namespace


SideColor Property

City Based Parking and Routing System API Documentation

BusStop.SideColor Property

The color to fill the cell with.

public System.Drawing.Color SideColor {get;}

Implements

ISideObject.SideColor

See Also

BusStop Class | CBPRS.Parking Namespace


StoppageTime Property

City Based Parking and Routing System API Documentation

BusStop.StoppageTime Property

Gets or sets the stoppage time for buses.

public int StoppageTime {get; set;}

See Also

BusStop Class | CBPRS.Parking Namespace


DijkstraParkingVehicle Class

Default Dijkstra vehicle for parking.

For a list of all members of this type, see DijkstraParkingVehicle Members.

System.Object
CBPRS.Infrastructure.Vehicle
CBPRS.Parking.DijkstraParkingVehicle

public class DijkstraParkingVehicle : Vehicle

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

DijkstraParkingVehicle Members | CBPRS.Parking Namespace


DijkstraParkingVehicle Members

DijkstraParkingVehicle overview

Public Static Methods

Create Factory Method

Protected Static Fields

cMaxAttemptsAtParking | The attempts the vehicle make to park.
cTimeRequiredToPark | The period of time consumed on the road while parking.
cTimeRequiredToTurn | The period of time consumed while turning on the road.

Public Instance Constructors

DijkstraParkingVehicle Constructor Default constructor.

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the vehicle.
MaxSpeed | Gets the maximum speed the vehicle is allowed to travel.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initializes the route to be followed towards a parking place.
Move | Moves the vehicle along the current lane.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the current route.

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_POnOtherLane | Boolean that indicates if the parking place is on the other lane.
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_PrakingAttempts | The number of parking attempts undertaken by the vehicle.
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_SearchingForPlace | Boolean that indicates if the vehicle is searching for a parking place.
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TargetLane | The lane the vehicle has targeted as its destination.
_TimeRemaining | The time remaining before the vehicle is parked.

Protected Instance Methods

ChooseRandomNextLane | Chooses a random next lane based on the set of valid directions.
ExecuteOtherLaneParkingProcedure | Execute parking procedure for parking place on other lane.
ExecuteParkingProcedure | Moves the vehicle along the current lane towards its parking place and parks it.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
RevertRoute | Reverts the vehicles routes so that it returns to starting point
SearchForParkingPlace | Searches the lanes for a specific parking place
SearchForPlace | The parking place search procedure
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle Constructor

Default constructor.

public DijkstraParkingVehicle(
int id
);

Parameters

id
The vehicle id.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle Fields

The fields of the DijkstraParkingVehicle class are listed below. For a complete list of DijkstraParkingVehicle class members, see the DijkstraParkingVehicle Members topic.

Protected Static Fields

cMaxAttemptsAtParking | The attempts the vehicle make to park.
cTimeRequiredToPark | The period of time consumed on the road while parking.
cTimeRequiredToTurn | The period of time consumed while turning on the road.

Protected Instance Fields

_Braking (inherited from CBPRS.Infrastructure.Vehicle) |
_Id (inherited from CBPRS.Infrastructure.Vehicle) |
_Lane (inherited from CBPRS.Infrastructure.Vehicle) |
_MustChange (inherited from CBPRS.Infrastructure.Vehicle) |
_POnOtherLane | Boolean that indicates if the parking place is on the other lane.
_Position (inherited from CBPRS.Infrastructure.Vehicle) |
_PrakingAttempts | The number of parking attempts undertaken by the vehicle.
_Route (inherited from CBPRS.Infrastructure.Vehicle) |
_SearchingForPlace | Boolean that indicates if the vehicle is searching for a parking place.
_Speed (inherited from CBPRS.Infrastructure.Vehicle) |
_TailLight (inherited from CBPRS.Infrastructure.Vehicle) |
_TargetLane | The lane the vehicle has targeted as its destination.
_TimeRemaining | The time remaining before the vehicle is parked.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle._POnOtherLane Field

Boolean that indicates if the parking place is on the other lane.

protected bool _POnOtherLane;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle._PrakingAttempts Field

The number of parking attempts undertaken by the vehicle.

protected int _PrakingAttempts;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle._SearchingForPlace Field

Boolean that indicates if the vehicle is searching for a parking place.

protected bool _SearchingForPlace;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle._TargetLane Field

The lane the vehicle has targeted as its destination.

protected ILane _TargetLane;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle._TimeRemaining Field

The time remaining before the vehicle is parked.

protected int _TimeRemaining;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.cMaxAttemptsAtParking Field

The attempts the vehicle make to park.

protected const int cMaxAttemptsAtParking = 5;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.cTimeRequiredToPark Field

The period of time consumed on the road while parking.

protected const int cTimeRequiredToPark = 5;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.cTimeRequiredToTurn Field

The period of time consumed while turning on the road.

protected const int cTimeRequiredToTurn = 10;

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle Properties

The properties of the DijkstraParkingVehicle class are listed below. For a complete list of DijkstraParkingVehicle class members, see the DijkstraParkingVehicle Members topic.

Public Instance Properties

Behind (inherited from CBPRS.Infrastructure.Vehicle) |
Color (inherited from CBPRS.Infrastructure.Vehicle) |
Id (inherited from CBPRS.Infrastructure.Vehicle) |
IsBraking (inherited from CBPRS.Infrastructure.Vehicle) |
Lane (inherited from CBPRS.Infrastructure.Vehicle) |
Length | Gets the length of the vehicle.
MaxSpeed | Gets the maximum speed the vehicle is allowed to travel.
MustChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
Position (inherited from CBPRS.Infrastructure.Vehicle) |
Route (inherited from CBPRS.Infrastructure.Vehicle) |
Speed (inherited from CBPRS.Infrastructure.Vehicle) |
TurnIndicator (inherited from CBPRS.Infrastructure.Vehicle) |

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


Length Property

City Based Parking and Routing System API Documentation

DijkstraParkingVehicle.Length Property

Gets the length of the vehicle.

public override int Length {get;}

Implements

IVehicle.Length

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


MaxSpeed Property

City Based Parking and Routing System API Documentation

DijkstraParkingVehicle.MaxSpeed Property

Gets the maximum speed the vehicle is allowed to travel.

public override int MaxSpeed {get;}

Implements

IVehicle.MaxSpeed

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle Methods

The methods of the DijkstraParkingVehicle class are listed below. For a complete list of DijkstraParkingVehicle class members, see the DijkstraParkingVehicle Members topic.

Public Static Methods

Create Factory Method

Public Instance Methods

BackwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeLanes (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeTo (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToLeft (inherited from CBPRS.Infrastructure.Vehicle) |
ChangeToRight (inherited from CBPRS.Infrastructure.Vehicle) |
CriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
ForwardGap (inherited from CBPRS.Infrastructure.Vehicle) |
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
IntializeRoute | Initializes the route to be followed towards a parking place.
Move | Moves the vehicle along the current lane.
PreCriticalZoneChange (inherited from CBPRS.Infrastructure.Vehicle) |
Reset (inherited from CBPRS.Infrastructure.Vehicle) |
ResolveLaneChangeDeadLock (inherited from CBPRS.Infrastructure.Vehicle) |
ToString (inherited from Object) | Returns a String that represents the current Object.
UpdateRoute | Updates the current route.

Protected Instance Methods

ChooseRandomNextLane | Chooses a random next lane based on the set of valid directions.
ExecuteOtherLaneParkingProcedure | Execute parking procedure for parking place on other lane.
ExecuteParkingProcedure | Moves the vehicle along the current lane towards its parking place and parks it.
Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.
MoveVehicle (inherited from CBPRS.Infrastructure.Vehicle) |
RevertRoute | Reverts the vehicles routes so that it returns to starting point
SearchForParkingPlace | Searches the lanes for a specific parking place
SearchForPlace | The parking place search procedure
SetTailLight (inherited from CBPRS.Infrastructure.Vehicle) |

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.ChooseRandomNextLane Method

Chooses a random next lane based on the set of valid directions.

protected void ChooseRandomNextLane(
IIntersection nextIs
);

Parameters

nextIs
The next intersection on the route.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.Create Method

Factory Method

public static IVehicle Create(
int id
);

Parameters

id
The id to be assigned to the vehicle.

Return Value

A newly created dijkstra parking vehicle with the specified id assigned.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.ExecuteOtherLaneParkingProcedure Method

Execute parking procedure for parking place on other lane.

protected void ExecuteOtherLaneParkingProcedure(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of the current.
step
The current simulation step.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.ExecuteParkingProcedure Method

Moves the vehicle along the current lane towards its parking place and parks it.

protected void ExecuteParkingProcedure(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of us on the same lane.
step
The current simulation time step.

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.IntializeRoute Method

Initializes the route to be followed towards a parking place.

public override void IntializeRoute(
IIntersection source,
uint step
);

Parameters

source
The source intersection at which the vehicle was spawned.
step
The current simulation time step.

Implements

IVehicle.IntializeRoute

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.Move Method

Moves the vehicle along the current lane.

public override void Move(
IVehicle vfront,
uint step
);

Parameters

vfront
The vehicle directly in front of us on the same lane.
step
The current simulation time step.

Implements

IVehicle.Move

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.RevertRoute Method

Reverts the vehicles routes so that it returns to starting point

protected void RevertRoute(
uint step
);

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.SearchForParkingPlace Method

Searches the lanes for a specific parking place

protected bool SearchForParkingPlace();

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.SearchForPlace Method

The parking place search procedure

protected void SearchForPlace();

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


DijkstraParkingVehicle.UpdateRoute Method

Updates the current route.

public override void UpdateRoute(
uint step
);

Parameters

step
The current simulation time step.

Implements

IVehicle.UpdateRoute

See Also

DijkstraParkingVehicle Class | CBPRS.Parking Namespace


IParking Interface

Default interface for a parking.

For a list of all members of this type, see IParking Members.

public interface IParking : ISideObject, ISimObject

Types that implement IParking

Type | Description
ParkingGarage | Parking garage that stores multiple parked vehicles
ParkingPlace | Class that represents a road side parking place

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

IParking Members | CBPRS.Parking Namespace


IParking Members

IParking overview

Public Instance Properties

IsFree | Gets a boolean that inidicates if the parking places if free.
IsFull | Gets a boolean that indicates that the parking place is full.
IsOccupied | Boolean indicating if the parking place is occupied.
IsReserved | Gets a boolean that indicates if the parking place is reserved.
Places | Gets the number of parking places on the current parking.
PlacesFree | Gets the number of places free on the current parking.
VehiclesParked | Gets the number of vehicles parked on the current parking.

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.

See Also

IParking Interface | CBPRS.Parking Namespace


IParking Properties

The properties of the IParking interface are listed below. For a complete list of IParking interface members, see the IParking Members topic.

Public Instance Properties

IsFree | Gets a boolean that inidicates if the parking places if free.
IsFull | Gets a boolean that indicates that the parking place is full.
IsOccupied | Boolean indicating if the parking place is occupied.
IsReserved | Gets a boolean that indicates if the parking place is reserved.
Places | Gets the number of parking places on the current parking.
PlacesFree | Gets the number of places free on the current parking.
VehiclesParked | Gets the number of vehicles parked on the current parking.

See Also

IParking Interface | CBPRS.Parking Namespace


IsFree Property

City Based Parking and Routing System API Documentation

IParking.IsFree Property

Gets a boolean that inidicates if the parking places if free.

bool IsFree {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


IsFull Property

City Based Parking and Routing System API Documentation

IParking.IsFull Property

Gets a boolean that indicates that the parking place is full.

bool IsFull {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


IsOccupied Property

City Based Parking and Routing System API Documentation

IParking.IsOccupied Property

Boolean indicating if the parking place is occupied.

bool IsOccupied {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


IsReserved Property

City Based Parking and Routing System API Documentation

IParking.IsReserved Property

Gets a boolean that indicates if the parking place is reserved.

bool IsReserved {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


Places Property

City Based Parking and Routing System API Documentation

IParking.Places Property

Gets the number of parking places on the current parking.

int Places {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


PlacesFree Property

City Based Parking and Routing System API Documentation

IParking.PlacesFree Property

Gets the number of places free on the current parking.

int PlacesFree {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


VehiclesParked Property

City Based Parking and Routing System API Documentation

IParking.VehiclesParked Property

Gets the number of vehicles parked on the current parking.

int VehiclesParked {get;}

See Also

IParking Interface | CBPRS.Parking Namespace


IParking Methods

The methods of the IParking interface are listed below. For a complete list of IParking interface members, see the IParking Members topic.

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.

See Also

IParking Interface | CBPRS.Parking Namespace


IParking.EjectVehicleOnRoad Method

Ejects a vehicle from the parking place and inserts in onto the road.

bool EjectVehicleOnRoad(
IVehicle vehicle,
uint timestep
);

Parameters

vehicle
The IVehicle to eject onto the road.
timestep
The current simulation time step.

Return Value

True if the vehicle was ejected sucessfully on the road.

See Also

IParking Interface | CBPRS.Parking Namespace


IParking.ParkVehicle Method

Parks a vehicle on the parking place.

void ParkVehicle(
IVehicle vehicle,
uint timestep
);

Parameters

vehicle
The IVehicle to park.
timestep
The time step at which the vehicle parks at the place.

See Also

IParking Interface | CBPRS.Parking Namespace


IParking.Reserve Method

Reserves the parking place for a certain vehicle.

bool Reserve();

Return Value

True if the parking place was reserved sucesfully.

See Also

IParking Interface | CBPRS.Parking Namespace


LampPost Class

The lamppost

For a list of all members of this type, see LampPost Members.

System.Object
CBPRS.Parking.LampPost

public class LampPost : ISimObject, ISideObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

LampPost Members | CBPRS.Parking Namespace


LampPost Members

LampPost overview

Public Instance Constructors

LampPost Constructor Default constructor

Public Instance Properties

Cell | Gets or sets the cell at which this object is located.
FillCell | Gets a boolean indicating if the cell should be filled.
GetParkingCount | Gets the number of parking places managed by this lamppost
Id | The pseudo-unique of the lamppost.
Indicator | Gets the legend indicator of the side object.
Lane | Gets or sets the ILane this lamppost is adjacent to.
SideColor | Gets the color to fill the cell with.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFreeParkingPlace | Retrieves a randomly chosen free parking place.
GetFreePlaces | Gets the number of free places managed by this lamppost.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Rests the lamppost
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Cell | The cell at which the lamppost is located.
_Id | The pseudo unique id of the lamppost.
_Lane | The lane this object is attached to.
_Parkings | The dictionary of parking places monitored by this system.
_Station | The sector station to which this lamppost belongs.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost Constructor

Default constructor

public LampPost(
int id
);

Parameters

id
The pseudo unique id of the lamppost.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost Fields

The fields of the LampPost class are listed below. For a complete list of LampPost class members, see the LampPost Members topic.

Protected Instance Fields

_Cell | The cell at which the lamppost is located.
_Id | The pseudo unique id of the lamppost.
_Lane | The lane this object is attached to.
_Parkings | The dictionary of parking places monitored by this system.
_Station | The sector station to which this lamppost belongs.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost._Cell Field

The cell at which the lamppost is located.

protected int _Cell;

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost._Id Field

The pseudo unique id of the lamppost.

protected int _Id;

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost._Lane Field

The lane this object is attached to.

protected ILane _Lane;

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost._Parkings Field

The dictionary of parking places monitored by this system.

protected 0, Culture=neutral, PublicKeyToken=null]] _Parkings;

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost._Station Field

The sector station to which this lamppost belongs.

protected SectorStation _Station;

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost Properties

The properties of the LampPost class are listed below. For a complete list of LampPost class members, see the LampPost Members topic.

Public Instance Properties

Cell | Gets or sets the cell at which this object is located.
FillCell | Gets a boolean indicating if the cell should be filled.
GetParkingCount | Gets the number of parking places managed by this lamppost
Id | The pseudo-unique of the lamppost.
Indicator | Gets the legend indicator of the side object.
Lane | Gets or sets the ILane this lamppost is adjacent to.
SideColor | Gets the color to fill the cell with.

See Also

LampPost Class | CBPRS.Parking Namespace


Cell Property

City Based Parking and Routing System API Documentation

LampPost.Cell Property

Gets or sets the cell at which this object is located.

public int Cell {get; set;}

Implements

ISideObject.Cell

See Also

LampPost Class | CBPRS.Parking Namespace


FillCell Property

City Based Parking and Routing System API Documentation

LampPost.FillCell Property

Gets a boolean indicating if the cell should be filled.

public bool FillCell {get;}

Implements

ISideObject.FillCell

See Also

LampPost Class | CBPRS.Parking Namespace


GetParkingCount Property

City Based Parking and Routing System API Documentation

LampPost.GetParkingCount Property

Gets the number of parking places managed by this lamppost

public int GetParkingCount {get;}

See Also

LampPost Class | CBPRS.Parking Namespace


Id Property

City Based Parking and Routing System API Documentation

LampPost.Id Property

The pseudo-unique of the lamppost.

public int Id {get; set;}

Implements

ISimObject.Id

See Also

LampPost Class | CBPRS.Parking Namespace


Indicator Property

City Based Parking and Routing System API Documentation

LampPost.Indicator Property

Gets the legend indicator of the side object.

public string Indicator {get;}

Implements

ISideObject.Indicator

See Also

LampPost Class | CBPRS.Parking Namespace


Lane Property

City Based Parking and Routing System API Documentation

LampPost.Lane Property

Gets or sets the ILane this lamppost is adjacent to.

public CBPRS.Infrastructure.ILane Lane {get; set;}

Implements

ISideObject.Lane

See Also

LampPost Class | CBPRS.Parking Namespace


SideColor Property

City Based Parking and Routing System API Documentation

LampPost.SideColor Property

Gets the color to fill the cell with.

public System.Drawing.Color SideColor {get;}

Implements

ISideObject.SideColor

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost Methods

The methods of the LampPost class are listed below. For a complete list of LampPost class members, see the LampPost Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetFreeParkingPlace | Retrieves a randomly chosen free parking place.
GetFreePlaces | Gets the number of free places managed by this lamppost.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
Reset | Rests the lamppost
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost.GetFreeParkingPlace Method

Retrieves a randomly chosen free parking place.

public IParking GetFreeParkingPlace(
int rnd
);

Parameters

rnd
the random seed.

Return Value

a free parking place if availible; Otherwise, false.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost.GetFreePlaces Method

Gets the number of free places managed by this lamppost.

public int GetFreePlaces();

Return Value

The number of free places.

See Also

LampPost Class | CBPRS.Parking Namespace


LampPost.Reset Method

Rests the lamppost

public void Reset();

Implements

ISimObject.Reset

See Also

LampPost Class | CBPRS.Parking Namespace


ParkingGarage Class

Parking garage that stores multiple parked vehicles

For a list of all members of this type, see ParkingGarage Members.

System.Object
CBPRS.Parking.ParkingGarage

public class ParkingGarage : IParking, ISideObject, ISimObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

ParkingGarage Members | CBPRS.Parking Namespace


ParkingGarage Members

ParkingGarage overview

Protected Static Fields

cDefaultPlaces | Default number of parking places in the garage.
cDefaultPrice | Default price per hour in the parking garage.

Public Instance Constructors

ParkingGarage Constructor Default constructor

Public Instance Properties

Cell | Gets the cell that is the entry of the current parking garage.
FillCell | Gets a boolean indicating if the cell should be filled.
Id | Gets the pseudo-unique id of the parking garage.
Indicator | Gets the legend indicator to draw.
IsFree | Gets a boolean that indicates that the parking place is free.
IsFull | Gets a boolean that indicates whether the parking place is full.
IsOccupied | Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.
IsReserved | Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.
Lane | Gets or sets the lane at which the parking garage is located.
Places | Get or sets the number of places in the garage.
PlacesFree | Gets the number of places free in the garage
PricePerHour | Gets or sets the price per hour.
SideColor | The color to fill the objects cell with
VehiclesParked | Gets the number of vehicles parked in the garage

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.
Reset | Resets the parking garage.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Cell | The cells occupied by the garage.
_Id | The pseudo unique id of the parking garage.
_Lane | The lane alongside which the garage resides.
_Occupied | The number of places occupied.
_Places | The number of places in the garage.
_PricePerHour | The parking price per hour.
_Reservations | The number of parking places reserved.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage Constructor

Default constructor

public ParkingGarage(
int Id
);

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage Fields

The fields of the ParkingGarage class are listed below. For a complete list of ParkingGarage class members, see the ParkingGarage Members topic.

Protected Static Fields

cDefaultPlaces | Default number of parking places in the garage.
cDefaultPrice | Default price per hour in the parking garage.

Protected Instance Fields

_Cell | The cells occupied by the garage.
_Id | The pseudo unique id of the parking garage.
_Lane | The lane alongside which the garage resides.
_Occupied | The number of places occupied.
_Places | The number of places in the garage.
_PricePerHour | The parking price per hour.
_Reservations | The number of parking places reserved.

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Cell Field

The cells occupied by the garage.

protected int _Cell;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Id Field

The pseudo unique id of the parking garage.

protected int _Id;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Lane Field

The lane alongside which the garage resides.

protected ILane _Lane;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Occupied Field

The number of places occupied.

protected int _Occupied;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Places Field

The number of places in the garage.

protected int _Places;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._PricePerHour Field

The parking price per hour.

protected float _PricePerHour;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage._Reservations Field

The number of parking places reserved.

protected int _Reservations;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.cDefaultPlaces Field

Default number of parking places in the garage.

protected const int cDefaultPlaces = 100;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.cDefaultPrice Field

Default price per hour in the parking garage.

protected const float cDefaultPrice = 4,5;

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage Properties

The properties of the ParkingGarage class are listed below. For a complete list of ParkingGarage class members, see the ParkingGarage Members topic.

Public Instance Properties

Cell | Gets the cell that is the entry of the current parking garage.
FillCell | Gets a boolean indicating if the cell should be filled.
Id | Gets the pseudo-unique id of the parking garage.
Indicator | Gets the legend indicator to draw.
IsFree | Gets a boolean that indicates that the parking place is free.
IsFull | Gets a boolean that indicates whether the parking place is full.
IsOccupied | Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.
IsReserved | Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.
Lane | Gets or sets the lane at which the parking garage is located.
Places | Get or sets the number of places in the garage.
PlacesFree | Gets the number of places free in the garage
PricePerHour | Gets or sets the price per hour.
SideColor | The color to fill the objects cell with
VehiclesParked | Gets the number of vehicles parked in the garage

See Also

ParkingGarage Class | CBPRS.Parking Namespace


Cell Property

City Based Parking and Routing System API Documentation

ParkingGarage.Cell Property

Gets the cell that is the entry of the current parking garage.

public int Cell {get; set;}

Implements

ISideObject.Cell

See Also

ParkingGarage Class | CBPRS.Parking Namespace


FillCell Property

City Based Parking and Routing System API Documentation

ParkingGarage.FillCell Property

Gets a boolean indicating if the cell should be filled.

public bool FillCell {get;}

Implements

ISideObject.FillCell

See Also

ParkingGarage Class | CBPRS.Parking Namespace


Id Property

City Based Parking and Routing System API Documentation

ParkingGarage.Id Property

Gets the pseudo-unique id of the parking garage.

public int Id {get; set;}

Implements

ISimObject.Id

See Also

ParkingGarage Class | CBPRS.Parking Namespace


Indicator Property

City Based Parking and Routing System API Documentation

ParkingGarage.Indicator Property

Gets the legend indicator to draw.

public string Indicator {get;}

Implements

ISideObject.Indicator

See Also

ParkingGarage Class | CBPRS.Parking Namespace


IsFree Property

City Based Parking and Routing System API Documentation

ParkingGarage.IsFree Property

Gets a boolean that indicates that the parking place is free.

public bool IsFree {get;}

Implements

IParking.IsFree

See Also

ParkingGarage Class | CBPRS.Parking Namespace


IsFull Property

City Based Parking and Routing System API Documentation

ParkingGarage.IsFull Property

Gets a boolean that indicates whether the parking place is full.

public bool IsFull {get;}

Implements

IParking.IsFull

See Also

ParkingGarage Class | CBPRS.Parking Namespace


IsOccupied Property

City Based Parking and Routing System API Documentation

ParkingGarage.IsOccupied Property

Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.

public bool IsOccupied {get;}

Implements

IParking.IsOccupied

See Also

ParkingGarage Class | CBPRS.Parking Namespace


IsReserved Property

City Based Parking and Routing System API Documentation

ParkingGarage.IsReserved Property

Gets a boolean that indicates whether the parking places occupied plus reservation fill the capacity of the garage.

public bool IsReserved {get;}

Implements

IParking.IsReserved

See Also

ParkingGarage Class | CBPRS.Parking Namespace


Lane Property

City Based Parking and Routing System API Documentation

ParkingGarage.Lane Property

Gets or sets the lane at which the parking garage is located.

public CBPRS.Infrastructure.ILane Lane {get; set;}

Implements

ISideObject.Lane

See Also

ParkingGarage Class | CBPRS.Parking Namespace


Places Property

City Based Parking and Routing System API Documentation

ParkingGarage.Places Property

Get or sets the number of places in the garage.

public int Places {get; set;}

Implements

IParking.Places

See Also

ParkingGarage Class | CBPRS.Parking Namespace


PlacesFree Property

City Based Parking and Routing System API Documentation

ParkingGarage.PlacesFree Property

Gets the number of places free in the garage

public int PlacesFree {get;}

Implements

IParking.PlacesFree

See Also

ParkingGarage Class | CBPRS.Parking Namespace


PricePerHour Property

City Based Parking and Routing System API Documentation

ParkingGarage.PricePerHour Property

Gets or sets the price per hour.

public float PricePerHour {get; set;}

See Also

ParkingGarage Class | CBPRS.Parking Namespace


SideColor Property

City Based Parking and Routing System API Documentation

ParkingGarage.SideColor Property

The color to fill the objects cell with

public System.Drawing.Color SideColor {get;}

Implements

ISideObject.SideColor

See Also

ParkingGarage Class | CBPRS.Parking Namespace


VehiclesParked Property

City Based Parking and Routing System API Documentation

ParkingGarage.VehiclesParked Property

Gets the number of vehicles parked in the garage

public int VehiclesParked {get;}

Implements

IParking.VehiclesParked

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage Methods

The methods of the ParkingGarage class are listed below. For a complete list of ParkingGarage class members, see the ParkingGarage Members topic.

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.
Reset | Resets the parking garage.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.EjectVehicleOnRoad Method

Ejects a vehicle from the parking place and inserts in onto the road.

public bool EjectVehicleOnRoad(
IVehicle vehicle,
uint timestep
);

Parameters

vehicle
The IVehicle to eject onto the road.
timestep
The current simulation time step.

Return Value

True if the vehicle was ejected sucessfully on the road.

Implements

IParking.EjectVehicleOnRoad

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.ParkVehicle Method

Parks a vehicle on the parking place.

public void ParkVehicle(
IVehicle vehicle,
uint period
);

Parameters

vehicle
The IVehicle to park.
period
The period of time the vehicle intends to park.

Implements

IParking.ParkVehicle

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.Reserve Method

Reserves the parking place for a certain vehicle.

public bool Reserve();

Return Value

True if the parking place was reserved sucesfully.

Implements

IParking.Reserve

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingGarage.Reset Method

Resets the parking garage.

public void Reset();

Implements

ISimObject.Reset

See Also

ParkingGarage Class | CBPRS.Parking Namespace


ParkingPlace Class

Class that represents a road side parking place

For a list of all members of this type, see ParkingPlace Members.

System.Object
CBPRS.Parking.ParkingPlace

public class ParkingPlace : IParking, ISideObject, ISimObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

ParkingPlace Members | CBPRS.Parking Namespace


ParkingPlace Members

ParkingPlace overview

Protected Static Fields

cParkingPlaces The number of parking places.

Public Instance Constructors

ParkingPlace Constructor Default constructor

Public Instance Properties

Cell | Gets or sets the cell at which this parking place resides.
FillCell | Should the cell be filled with the presented color ?
Id | Gets the id of the parking place.
Indicator | The legend indicator of the side object
IsFree | Gets a boolean that indicates that the parking place is free.
IsFull | Gets a boolean that indicates that the parking place is full.
IsOccupied | Boolean indicating if the parking place is occupied.
IsReserved | Gets a boolean that indicates if the parking place is reserved.
Lane | Gets or sets the lane to which this parking place is attached.
Places | Gets the number of parking places on the current parking.
PlacesFree | Gets the number of places free on the current parking.
SideColor | The color to fill the cell of the side object with
VehiclesParked | Gets the number of vehicles parked on the current parking.

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.
Reset | Resets the parking place
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Cell | The cell that indicates the position along the lane.
_Id | The pseudo unique id of the parking place.
_Lane | The lane that connects to this parking place.
_Status | The current status of the parking system.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace Constructor

Default constructor

public ParkingPlace(
int id
);

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace Fields

The fields of the ParkingPlace class are listed below. For a complete list of ParkingPlace class members, see the ParkingPlace Members topic.

Protected Static Fields

cParkingPlaces The number of parking places.

Protected Instance Fields

_Cell | The cell that indicates the position along the lane.
_Id | The pseudo unique id of the parking place.
_Lane | The lane that connects to this parking place.
_Status | The current status of the parking system.

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace._Cell Field

The cell that indicates the position along the lane.

protected int _Cell;

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace._Id Field

The pseudo unique id of the parking place.

protected int _Id;

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace._Lane Field

The lane that connects to this parking place.

protected ILane _Lane;

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace._Status Field

The current status of the parking system.

protected ParkingPlaceStatus _Status;

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace.cParkingPlaces Field

The number of parking places.

protected const int cParkingPlaces = 1;

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace Properties

The properties of the ParkingPlace class are listed below. For a complete list of ParkingPlace class members, see the ParkingPlace Members topic.

Public Instance Properties

Cell | Gets or sets the cell at which this parking place resides.
FillCell | Should the cell be filled with the presented color ?
Id | Gets the id of the parking place.
Indicator | The legend indicator of the side object
IsFree | Gets a boolean that indicates that the parking place is free.
IsFull | Gets a boolean that indicates that the parking place is full.
IsOccupied | Boolean indicating if the parking place is occupied.
IsReserved | Gets a boolean that indicates if the parking place is reserved.
Lane | Gets or sets the lane to which this parking place is attached.
Places | Gets the number of parking places on the current parking.
PlacesFree | Gets the number of places free on the current parking.
SideColor | The color to fill the cell of the side object with
VehiclesParked | Gets the number of vehicles parked on the current parking.

See Also

ParkingPlace Class | CBPRS.Parking Namespace


Cell Property

City Based Parking and Routing System API Documentation

ParkingPlace.Cell Property

Gets or sets the cell at which this parking place resides.

public int Cell {get; set;}

Implements

ISideObject.Cell

See Also

ParkingPlace Class | CBPRS.Parking Namespace


FillCell Property

City Based Parking and Routing System API Documentation

ParkingPlace.FillCell Property

Should the cell be filled with the presented color ?

public bool FillCell {get;}

Implements

ISideObject.FillCell

See Also

ParkingPlace Class | CBPRS.Parking Namespace


Id Property

City Based Parking and Routing System API Documentation

ParkingPlace.Id Property

Gets the id of the parking place.

public int Id {get; set;}

Implements

ISimObject.Id

See Also

ParkingPlace Class | CBPRS.Parking Namespace


Indicator Property

City Based Parking and Routing System API Documentation

ParkingPlace.Indicator Property

The legend indicator of the side object

public string Indicator {get;}

Implements

ISideObject.Indicator

See Also

ParkingPlace Class | CBPRS.Parking Namespace


IsFree Property

City Based Parking and Routing System API Documentation

ParkingPlace.IsFree Property

Gets a boolean that indicates that the parking place is free.

public bool IsFree {get;}

Implements

IParking.IsFree

See Also

ParkingPlace Class | CBPRS.Parking Namespace


IsFull Property

City Based Parking and Routing System API Documentation

ParkingPlace.IsFull Property

Gets a boolean that indicates that the parking place is full.

public bool IsFull {get;}

Implements

IParking.IsFull

See Also

ParkingPlace Class | CBPRS.Parking Namespace


IsOccupied Property

City Based Parking and Routing System API Documentation

ParkingPlace.IsOccupied Property

Boolean indicating if the parking place is occupied.

public bool IsOccupied {get;}

Implements

IParking.IsOccupied

See Also

ParkingPlace Class | CBPRS.Parking Namespace


IsReserved Property

City Based Parking and Routing System API Documentation

ParkingPlace.IsReserved Property

Gets a boolean that indicates if the parking place is reserved.

public bool IsReserved {get;}

Implements

IParking.IsReserved

See Also

ParkingPlace Class | CBPRS.Parking Namespace


Lane Property

City Based Parking and Routing System API Documentation

ParkingPlace.Lane Property

Gets or sets the lane to which this parking place is attached.

public CBPRS.Infrastructure.ILane Lane {get; set;}

Implements

ISideObject.Lane

See Also

ParkingPlace Class | CBPRS.Parking Namespace


Places Property

City Based Parking and Routing System API Documentation

ParkingPlace.Places Property

Gets the number of parking places on the current parking.

public int Places {get;}

Implements

IParking.Places

See Also

ParkingPlace Class | CBPRS.Parking Namespace


PlacesFree Property

City Based Parking and Routing System API Documentation

ParkingPlace.PlacesFree Property

Gets the number of places free on the current parking.

public int PlacesFree {get;}

Implements

IParking.PlacesFree

See Also

ParkingPlace Class | CBPRS.Parking Namespace


SideColor Property

City Based Parking and Routing System API Documentation

ParkingPlace.SideColor Property

The color to fill the cell of the side object with

public System.Drawing.Color SideColor {get;}

Implements

ISideObject.SideColor

See Also

ParkingPlace Class | CBPRS.Parking Namespace


VehiclesParked Property

City Based Parking and Routing System API Documentation

ParkingPlace.VehiclesParked Property

Gets the number of vehicles parked on the current parking.

public int VehiclesParked {get;}

Implements

IParking.VehiclesParked

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace Methods

The methods of the ParkingPlace class are listed below. For a complete list of ParkingPlace class members, see the ParkingPlace Members topic.

Public Instance Methods

EjectVehicleOnRoad | Ejects a vehicle from the parking place and inserts in onto the road.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ParkVehicle | Parks a vehicle on the parking place.
Reserve | Reserves the parking place for a certain vehicle.
Reset | Resets the parking place
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace.EjectVehicleOnRoad Method

Ejects a vehicle from the parking place and inserts in onto the road.

public bool EjectVehicleOnRoad(
IVehicle vehicle,
uint timestep
);

Parameters

vehicle
The IVehicle to eject onto the road.
timestep
The simulation timestep at which to eject the vehicle.

Return Value

True if the vehicle was ejected sucessfully on the road.

Implements

IParking.EjectVehicleOnRoad

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace.ParkVehicle Method

Parks a vehicle on the parking place.

public void ParkVehicle(
IVehicle vehicle,
uint period
);

Parameters

vehicle
The IVehicle to park.
period
The period that the vehicle intends to stay.

Implements

IParking.ParkVehicle

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace.Reserve Method

Reserves the parking place for a certain vehicle.

public bool Reserve();

Return Value

True if the parking place was reserved sucesfully.

Implements

IParking.Reserve

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlace.Reset Method

Resets the parking place

public void Reset();

Implements

ISimObject.Reset

See Also

ParkingPlace Class | CBPRS.Parking Namespace


ParkingPlaceStatus Enumeration

Enumeration of the different states a parking place can have.

public enum ParkingPlaceStatus

Members

Member Name | Description
Free | The parking place is free.
Reserved | The parking place is reserved by the parking system.
Occupied | The parking place is occupied.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

CBPRS.Parking Namespace


ParkingSlot Class

A parking slot that allows a vehicle to be parked for a certain period.

For a list of all members of this type, see ParkingSlot Members.

System.Object
CBPRS.Parking.ParkingSlot

public class ParkingSlot

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

ParkingSlot Members | CBPRS.Parking Namespace


ParkingSlot Members

ParkingSlot overview

Public Instance Constructors

ParkingSlot Constructor Default constructor

Public Instance Properties

Parking | Gets the parking at which the vehicle is parked.
Vehicle | Gets the vehicle in the current slot.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetType (inherited from Object) | Gets the Type of the current instance.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Parking | The parking at which the vehicle is parked.
_Vehicle | The vehicle in the current slot.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSlot Constructor

Default constructor

public ParkingSlot(
IVehicle vehicle,
IParking parking
);

Parameters

vehicle
The vehicle in the current slot.
parking
The parking at which the vehicle is parked.

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSlot Fields

The fields of the ParkingSlot class are listed below. For a complete list of ParkingSlot class members, see the ParkingSlot Members topic.

Protected Instance Fields

_Parking | The parking at which the vehicle is parked.
_Vehicle | The vehicle in the current slot.

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSlot._Parking Field

The parking at which the vehicle is parked.

protected IParking _Parking;

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSlot._Vehicle Field

The vehicle in the current slot.

protected IVehicle _Vehicle;

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSlot Properties

The properties of the ParkingSlot class are listed below. For a complete list of ParkingSlot class members, see the ParkingSlot Members topic.

Public Instance Properties

Parking | Gets the parking at which the vehicle is parked.
Vehicle | Gets the vehicle in the current slot.

See Also

ParkingSlot Class | CBPRS.Parking Namespace


Parking Property

City Based Parking and Routing System API Documentation

ParkingSlot.Parking Property

Gets the parking at which the vehicle is parked.

public IParking Parking {get;}

See Also

ParkingSlot Class | CBPRS.Parking Namespace


Vehicle Property

City Based Parking and Routing System API Documentation

ParkingSlot.Vehicle Property

Gets the vehicle in the current slot.

public CBPRS.Infrastructure.IVehicle Vehicle {get;}

See Also

ParkingSlot Class | CBPRS.Parking Namespace


ParkingSystem Class

The parking system (facade)

For a list of all members of this type, see ParkingSystem Members.

System.Object
CBPRS.Parking.ParkingSystem

public sealed class ParkingSystem : ISubSystem

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

ParkingSystem Members | CBPRS.Parking Namespace


ParkingSystem Members

ParkingSystem overview

Public Static Fields

sOccupiedPlaces | The number of occupied places.
sParkedVehicles | The number of vehicles parked.
sParkingTime | The number of time consumed by parking.
sPlaces | The number of parking places in the parking system.
sReservedPlaces | The number of reserved parking places.

Public Static Methods

GetInstance | Gets the singleton instance of the parking system.
VehicleIsParked | Method to keep track of the average parking time.

Public Instance Properties

GetBusRoutesEnumerator | Gets the enumerator over all bus routes.
GetLayer | Gets the piccolo layer managed by this sub system.
GetParkingAdminSystem | Gets the parking administration part of the parking system.

Public Instance Methods

CreateBusStop | Creates a new bus stop on the specified route.
CreateLampPost | Creates a lamppost.
CreateParkingGarage | Creates a parking garage.
CreateParkingPlace | Creates a parking place.
CreateSectorStation | Creates a new Parking sector station.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBusRoute | Gets an enumerator for the route.
GetBusStopCountOnRoute | Gets the number of bus stops for the specified route.
GetFullBusRoute | Gets the full bus route.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetParking | Gets a ParkingPlace or ParkingGarage from the system.
GetRandomParking | Gets a random ParkingPlace or ParkingGarage
GetRandomParkingNoChecks | Gets a random ParkingPlace or ParkingGarage without check if they are availible.
GetSectorStation | Gets the sector station with the specified id.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Intializes the parking system.
IsBusRouteValid | Determines if the specified route id refers to a valid bus route.
RegisterSurrogate | Registers a surrogate with the specified surrogate selector
RemoveBusRoute | Removes an entire bus route including all bus stops.
RemoveBusStopFromRoute | Removes a bus stop from a specified route.
RemoveParking | Removes a ParkingPlace or ParkingGarage from the system.
RemoveSectorStation | Removes the specified sector station form the collection.
Reset | Resets the current subsystem
SetObjectData | Populates the singleton with the data stored in the SerializationInfo class.
Simulate | The simulation method of the parking system.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem Fields

The fields of the ParkingSystem class are listed below. For a complete list of ParkingSystem class members, see the ParkingSystem Members topic.

Public Static Fields

sOccupiedPlaces | The number of occupied places.
sParkedVehicles | The number of vehicles parked.
sParkingTime | The number of time consumed by parking.
sPlaces | The number of parking places in the parking system.
sReservedPlaces | The number of reserved parking places.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.sOccupiedPlaces Field

The number of occupied places.

public static uint sOccupiedPlaces;

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.sParkedVehicles Field

The number of vehicles parked.

public static uint sParkedVehicles;

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.sParkingTime Field

The number of time consumed by parking.

public static ulong sParkingTime;

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.sPlaces Field

The number of parking places in the parking system.

public static uint sPlaces;

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.sReservedPlaces Field

The number of reserved parking places.

public static uint sReservedPlaces;

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem Properties

The properties of the ParkingSystem class are listed below. For a complete list of ParkingSystem class members, see the ParkingSystem Members topic.

Public Instance Properties

GetBusRoutesEnumerator | Gets the enumerator over all bus routes.
GetLayer | Gets the piccolo layer managed by this sub system.
GetParkingAdminSystem | Gets the parking administration part of the parking system.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


GetBusRoutesEnumerator Property

City Based Parking and Routing System API Documentation

ParkingSystem.GetBusRoutesEnumerator Property

Gets the enumerator over all bus routes.

public System.Collections.Generic.IEnumerator`1[[System.Int32, mscorlib, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]] GetBusRoutesEnumerator {get;}

See Also

ParkingSystem Class | CBPRS.Parking Namespace


GetLayer Property

City Based Parking and Routing System API Documentation

ParkingSystem.GetLayer Property

Gets the piccolo layer managed by this sub system.

public UMD.HCIL.Piccolo.PLayer GetLayer {get;}

Implements

ISubSystem.GetLayer

See Also

ParkingSystem Class | CBPRS.Parking Namespace


GetParkingAdminSystem Property

City Based Parking and Routing System API Documentation

ParkingSystem.GetParkingAdminSystem Property

Gets the parking administration part of the parking system.

public AdminSystem GetParkingAdminSystem {get;}

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem Methods

The methods of the ParkingSystem class are listed below. For a complete list of ParkingSystem class members, see the ParkingSystem Members topic.

Public Static Methods

GetInstance | Gets the singleton instance of the parking system.
VehicleIsParked | Method to keep track of the average parking time.

Public Instance Methods

CreateBusStop | Creates a new bus stop on the specified route.
CreateLampPost | Creates a lamppost.
CreateParkingGarage | Creates a parking garage.
CreateParkingPlace | Creates a parking place.
CreateSectorStation | Creates a new Parking sector station.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetBusRoute | Gets an enumerator for the route.
GetBusStopCountOnRoute | Gets the number of bus stops for the specified route.
GetFullBusRoute | Gets the full bus route.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetParking | Gets a ParkingPlace or ParkingGarage from the system.
GetRandomParking | Gets a random ParkingPlace or ParkingGarage
GetRandomParkingNoChecks | Gets a random ParkingPlace or ParkingGarage without check if they are availible.
GetSectorStation | Gets the sector station with the specified id.
GetType (inherited from Object) | Gets the Type of the current instance.
Initialize | Intializes the parking system.
IsBusRouteValid | Determines if the specified route id refers to a valid bus route.
RegisterSurrogate | Registers a surrogate with the specified surrogate selector
RemoveBusRoute | Removes an entire bus route including all bus stops.
RemoveBusStopFromRoute | Removes a bus stop from a specified route.
RemoveParking | Removes a ParkingPlace or ParkingGarage from the system.
RemoveSectorStation | Removes the specified sector station form the collection.
Reset | Resets the current subsystem
SetObjectData | Populates the singleton with the data stored in the SerializationInfo class.
Simulate | The simulation method of the parking system.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.CreateBusStop Method

Creates a new bus stop on the specified route.

public BusStop CreateBusStop(
int routeid
);

Parameters

routeid
The route id of the new bus stop.

Return Value

The newly created BusStop object.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.CreateLampPost Method

Creates a lamppost.

public LampPost CreateLampPost();

Return Value

A new LampPost object

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.CreateParkingGarage Method

Creates a parking garage.

public IParking CreateParkingGarage();

Return Value

A new ParkingGarage object.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.CreateParkingPlace Method

Creates a parking place.

public IParking CreateParkingPlace();

Return Value

A new ParkingPlace object.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.CreateSectorStation Method

Creates a new Parking sector station.

public SectorStation CreateSectorStation(
int id
);

Parameters

id
The id to assign to the sector station.

Return Value

A new SectorStation with the specified id assigned.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetBusRoute Method

Gets an enumerator for the route.

public 0, Culture=neutral, PublicKeyToken=null]] GetBusRoute(
int routeId
);

Parameters

routeId
The route id to retrieve.

Return Value

An enumerator to a bus route.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetBusStopCountOnRoute Method

Gets the number of bus stops for the specified route.

public int GetBusStopCountOnRoute(
int routeId
);

Parameters

routeId
The route id to retrieve.

Return Value

The number of bus stops on a route

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetFullBusRoute Method

Gets the full bus route.

public 0, Culture=neutral, PublicKeyToken=null]] GetFullBusRoute(
int routeId
);

Parameters

routeId
The route id to retrieve.

Return Value

A list containg all the BusStop in a route.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetInstance Method

Gets the singleton instance of the parking system.

public static ParkingSystem GetInstance();

Return Value

The singleton instance of the parking system.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public void GetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISubSystem.GetObjectData

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetParking Method

Gets a ParkingPlace or ParkingGarage from the system.

public IParking GetParking(
int id
);

Parameters

id
The id of the parking to retrieve.

Return Value

The parking if found; Otherwise, null.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetRandomParking Method

Gets a random ParkingPlace or ParkingGarage

public IParking GetRandomParking();

Return Value

A randomly selected ParkingPlace or ParkingGarage.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetRandomParkingNoChecks Method

Gets a random ParkingPlace or ParkingGarage without check if they are availible.

public IParking GetRandomParkingNoChecks();

Return Value

A ParkingPlace or ParkingGarage object.

Remarks

This function is used when one does not care if a vehicle drives to an occupied parking.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.GetSectorStation Method

Gets the sector station with the specified id.

public SectorStation GetSectorStation(
int id
);

Parameters

id
The id of the sector station specified.

Return Value

The sector if present; Otherwise, null.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.Initialize Method

Intializes the parking system.

public void Initialize();

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.IsBusRouteValid Method

Determines if the specified route id refers to a valid bus route.

public bool IsBusRouteValid(
int routeId
);

Parameters

routeId
The route id to validate.

Return Value

True if the route is valid; Otherwise, false.

Remarks

The dijkstra algorithm should be ran on the infrastructure before using this function!

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.RegisterSurrogate Method

Registers a surrogate with the specified surrogate selector

public void RegisterSurrogate(
SurrogateSelector selector
);

Parameters

selector
The global surrogate selector

Implements

ISubSystem.RegisterSurrogate

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.RemoveBusRoute Method

Removes an entire bus route including all bus stops.

public bool RemoveBusRoute(
int routeId
);

Parameters

routeId
The route id for the bus route.

Return Value

True if the bus route was sucesfully removed; Otherwise, false.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.RemoveBusStopFromRoute Method

Removes a bus stop from a specified route.

public bool RemoveBusStopFromRoute(
int routeId,
BusStop busstop
);

Parameters

routeId
The route id for the bus route.
busstop
The bus stop to remove.

Return Value

True if the bus stop was sucesfully removed; Otherwise, false.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.RemoveParking Method

Removes a ParkingPlace or ParkingGarage from the system.

public bool RemoveParking(
IParking parking
);

Parameters

parking
The parking place to remove.

Return Value

True if successfull; Otherwise, false.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.RemoveSectorStation Method

Removes the specified sector station form the collection.

public bool RemoveSectorStation(
int id
);

Parameters

id
The id of the sector station to remove.

Return Value

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.Reset Method

Resets the current subsystem

public void Reset();

Implements

ISubSystem.Reset

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.SetObjectData Method

Populates the singleton with the data stored in the SerializationInfo class.

public void SetObjectData(
SerializationInfo info,
StreamingContext context
);

Implements

ISubSystem.SetObjectData

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.Simulate Method

The simulation method of the parking system.

public void Simulate(
uint step
);

Parameters

step
The current simulation step.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystem.VehicleIsParked Method

Method to keep track of the average parking time.

public static void VehicleIsParked(
uint time,
bool reservation
);

Parameters

time
The time parked by the vehicle
reservation
boolean indicating if the vehicle had a reservation.

See Also

ParkingSystem Class | CBPRS.Parking Namespace


ParkingSystemSurrogate Class

Surrogate class for ParkingSystem de- / serialization.

For a list of all members of this type, see ParkingSystemSurrogate Members.

System.Object
CBPRS.Parking.ParkingSystemSurrogate

public sealed class ParkingSystemSurrogate : ISerializationSurrogate

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

ParkingSystemSurrogate Members | CBPRS.Parking Namespace


ParkingSystemSurrogate Members

ParkingSystemSurrogate overview

Public Instance Constructors

ParkingSystemSurrogate Constructor Initializes a new instance of the ParkingSystemSurrogate class.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the current instance.
SetObjectData | Populates the singleton with the data stored in the SerializationInfo class.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParkingSystemSurrogate Class | CBPRS.Parking Namespace


ParkingSystemSurrogate Constructor

Initializes a new instance of the ParkingSystemSurrogate class.

public ParkingSystemSurrogate();

See Also

ParkingSystemSurrogate Class | CBPRS.Parking Namespace


ParkingSystemSurrogate Methods

The methods of the ParkingSystemSurrogate class are listed below. For a complete list of ParkingSystemSurrogate class members, see the ParkingSystemSurrogate Members topic.

Public Instance Methods

Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
GetType (inherited from Object) | Gets the Type of the current instance.
SetObjectData | Populates the singleton with the data stored in the SerializationInfo class.
ToString (inherited from Object) | Returns a String that represents the current Object.

See Also

ParkingSystemSurrogate Class | CBPRS.Parking Namespace


ParkingSystemSurrogate.GetObjectData Method

Populates a SerializationInfo with the data needed to serialize the target object.

public void GetObjectData(
object obj,
SerializationInfo info,
StreamingContext context
);

Implements

ISerializationSurrogate.GetObjectData

See Also

ParkingSystemSurrogate Class | CBPRS.Parking Namespace


ParkingSystemSurrogate.SetObjectData Method

Populates the singleton with the data stored in the SerializationInfo class.

public object SetObjectData(
object obj,
SerializationInfo info,
StreamingContext context,
ISurrogateSelector selector
);

Return Value

A reference to the ParkingSystem class.

Implements

ISerializationSurrogate.SetObjectData

See Also

ParkingSystemSurrogate Class | CBPRS.Parking Namespace


SectorStation Class

Default sector station for the simulation environment.

For a list of all members of this type, see SectorStation Members.

System.Object
CBPRS.Parking.SectorStation

public class SectorStation : ISimObject

Thread Safety

Public static (Shared in Visual Basic) members of this type are safe for multithreaded operations. Instance members are not guaranteed to be thread-safe.

Requirements

Namespace: CBPRS.Parking

Assembly: CBPRS.Parking (in CBPRS.Parking.dll)

See Also

SectorStation Members | CBPRS.Parking Namespace


SectorStation Members

SectorStation overview

Public Static Fields

_Random Randomizer (Perhaps a Merssene twister would be better here).

Protected Static Fields

cDefPricePerHour Default price for a parking place ( not a garage these have their own tariff's )

Public Instance Constructors

SectorStation Constructor Default constructor.

Public Instance Properties

GetLampPostEnumerator | Gets an enumerator over all lampposts in the collection of the station.
Id | Gets the id of the sector station.
LampPosts | Gets the number of lampposts in the collection of the current station.

Public Instance Methods

AddLampPost | Adds a lamppost to the collection of lampposts operated by the current sector station.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLampPost | Gets a lamppost by the specified id.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveLampPost | Removes a lamppost from the collection of lampposts.
ReserveParkingPlace | Reserves a parking place.
Reset | Resets the sector station.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Fields

_Id | The pseudo-unique id of the sector station.
_Lampposts | The list of lampposts managed by this sector station.
_PlacesFree | The number of places free in the sector.
_PlacesOccupied | The number of places occupied in the sector.
_PlacesReserved | The places reserved in the sector.
_PricePerHour | Price per hour of a parking place in the current sector.
Revenue | The revenue in the current sector;

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation Constructor

Default constructor.

public SectorStation(
int id
);

Parameters

id
The pseudo-unique id of the sector station

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation Fields

The fields of the SectorStation class are listed below. For a complete list of SectorStation class members, see the SectorStation Members topic.

Public Static Fields

_Random Randomizer (Perhaps a Merssene twister would be better here).

Protected Static Fields

cDefPricePerHour Default price for a parking place ( not a garage these have their own tariff's )

Protected Instance Fields

_Id | The pseudo-unique id of the sector station.
_Lampposts | The list of lampposts managed by this sector station.
_PlacesFree | The number of places free in the sector.
_PlacesOccupied | The number of places occupied in the sector.
_PlacesReserved | The places reserved in the sector.
_PricePerHour | Price per hour of a parking place in the current sector.
Revenue | The revenue in the current sector;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._Id Field

The pseudo-unique id of the sector station.

protected int _Id;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._Lampposts Field

The list of lampposts managed by this sector station.

protected 0, Culture=neutral, PublicKeyToken=null]] _Lampposts;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._PlacesFree Field

The number of places free in the sector.

protected int _PlacesFree;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._PlacesOccupied Field

The number of places occupied in the sector.

protected int _PlacesOccupied;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._PlacesReserved Field

The places reserved in the sector.

protected int _PlacesReserved;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._PricePerHour Field

Price per hour of a parking place in the current sector.

protected float _PricePerHour;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation._Random Field

Randomizer (Perhaps a Merssene twister would be better here).

public static Random _Random;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.cDefPricePerHour Field

Default price for a parking place ( not a garage these have their own tariff's )

protected const float cDefPricePerHour = 1;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.Revenue Field

The revenue in the current sector;

protected double Revenue;

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation Properties

The properties of the SectorStation class are listed below. For a complete list of SectorStation class members, see the SectorStation Members topic.

Public Instance Properties

GetLampPostEnumerator | Gets an enumerator over all lampposts in the collection of the station.
Id | Gets the id of the sector station.
LampPosts | Gets the number of lampposts in the collection of the current station.

See Also

SectorStation Class | CBPRS.Parking Namespace


GetLampPostEnumerator Property

City Based Parking and Routing System API Documentation

SectorStation.GetLampPostEnumerator Property

Gets an enumerator over all lampposts in the collection of the station.

public LampPost, CBPRS.Parking, Version=1.0.0.0, Culture=neutral, PublicKeyToken=null]] GetLampPostEnumerator {get;}

See Also

SectorStation Class | CBPRS.Parking Namespace


Id Property

City Based Parking and Routing System API Documentation

SectorStation.Id Property

Gets the id of the sector station.

public int Id {get; set;}

Implements

ISimObject.Id

See Also

SectorStation Class | CBPRS.Parking Namespace


LampPosts Property

City Based Parking and Routing System API Documentation

SectorStation.LampPosts Property

Gets the number of lampposts in the collection of the current station.

public int LampPosts {get;}

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation Methods

The methods of the SectorStation class are listed below. For a complete list of SectorStation class members, see the SectorStation Members topic.

Public Instance Methods

AddLampPost | Adds a lamppost to the collection of lampposts operated by the current sector station.
Equals (inherited from Object) | Determines whether the specified Object is equal to the current Object.
GetHashCode (inherited from Object) | Serves as a hash function for a particular type. GetHashCode is suitable for use in hashing algorithms and data structures like a hash table.
GetLampPost | Gets a lamppost by the specified id.
GetType (inherited from Object) | Gets the Type of the current instance.
RemoveLampPost | Removes a lamppost from the collection of lampposts.
ReserveParkingPlace | Reserves a parking place.
Reset | Resets the sector station.
ToString (inherited from Object) | Returns a String that represents the current Object.

Protected Instance Methods

Finalize (inherited from Object) | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection.
MemberwiseClone (inherited from Object) | Creates a shallow copy of the current Object.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.AddLampPost Method

Adds a lamppost to the collection of lampposts operated by the current sector station.

public bool AddLampPost(
LampPost post
);

Parameters

post
The LampPost to add to the collection.

Return Value

True if the post was added; Otherwise, false.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.GetLampPost Method

Gets a lamppost by the specified id.

public LampPost GetLampPost(
uint id
);

Parameters

id
The id of the lamppost to retrieve.

Return Value

The lamppost with the specified id if present; Ohterwise, null.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.RemoveLampPost Method

Removes a lamppost from the collection of lampposts.

public bool RemoveLampPost(
LampPost post
);

Parameters

post
The LampPost to remove from the collection.

Return Value

True if the post was removed; Otherwise, false.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.ReserveParkingPlace Method

Reserves a parking place.

public ISideObject ReserveParkingPlace();

Return Value

The side object that repesents the parking facility to be used.

See Also

SectorStation Class | CBPRS.Parking Namespace


SectorStation.Reset Method

Resets the sector station.

public void Reset();

Implements

ISimObject.Reset

See Also

SectorStation Class | CBPRS.Parking Namespace


CBPRS.ParkingHierarchy

City Based Parking and Routing System API Documentation

CBPRS.Parking Hierarchy

System.Object
CBPRS.Infrastructure.Vehicle ---- CBPRS.Infrastructure.IVehicle, CBPRS.Simulation.ISimObject
CBPRS.Parking.AntParkingVehicle
CBPRS.Parking.Bus
CBPRS.Parking.DijkstraParkingVehicle
CBPRS.Parking.AdminSystem
CBPRS.Parking.BusStop ---- CBPRS.Infrastructure.ISideObject
CBPRS.Parking.IParking ---- CBPRS.Infrastructure.ISideObject, CBPRS.Simulation.ISimObject
CBPRS.Parking.LampPost ---- CBPRS.Infrastructure.ISideObject, CBPRS.Simulation.ISimObject
CBPRS.Parking.ParkingGarage ---- CBPRS.Infrastructure.ISideObject, CBPRS.Parking.IParking, CBPRS.Simulation.ISimObject
CBPRS.Parking.ParkingPlace ---- CBPRS.Infrastructure.ISideObject, CBPRS.Parking.IParking, CBPRS.Simulation.ISimObject
CBPRS.Parking.ParkingSlot
CBPRS.Parking.ParkingSystem ---- CBPRS.Simulation.ISubSystem
CBPRS.Parking.ParkingSystemSurrogate ---- System.Runtime.Serialization.ISerializationSurrogate
CBPRS.Parking.SectorStation ---- CBPRS.Simulation.ISimObject
System.ValueType
System.Enum ---- System.IComparable, System.IConvertible, System.IFormattable
CBPRS.Parking.ParkingPlaceStatus

See Also

CBPRS.Parking Namespace