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Have you seen Kung Fu Panda The Movie (2008)? It's the story about a lazy, irreverent slacker panda, named Po, who is the biggest fan 
of Kung Fu around. But unwittingly Po becomes the chosen one when enemies threaten the village he lived in. In this tutorial you will 
learn to create Po model, low poly model version. Don't compare the model you will create with the real one you saw in movie. I 
simplified many things. But at least you'll understand how to create one. I planned to create Po character from modeling, texturing, 
rigging and skinning, also animate him. So let's prepare for the first one: modeling.

Kung Fu Panda The Movie. I really love this movie.

1. First, we need a reference image. Too bad, I can't find any reference image I want in the net. So, I decide to draw myself. Look at 
image below, I prepared a blueprint for you, complete with Po drawing (left and side image). How to create blueprint like this, read 
previous tutorial Modeling Using Blueprint.

You can download 3dsmax file with blueprint here (3dsmax ver 8). 
Also you need to download bitmap images for blueprint

2. Start by creating a sphere in Top viewport. Use Radius=78 and Segments=12. Position this sphere at Po head (look at image below). 
Apply material to this sphere. Use Opacity=50% so you can see blueprint behind. You can use any color you want. Later, you can change 
Opacity value at ay time to help you in modeling.

Kung Fu Panda Modeling (1.1)
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3. In Left or Front viewport, move sphere down while holding Shift. You will get sphere clone. Use Copy for cloning method. In Command 
Panel, go to Modify tab, increate cloned sphere radius to 117. Place this cloned sphere in Po's belly. Select one sphere—any sphere 
you want—then right click and choose Convert to>Convert to Editable Poly. Next, go to Modify tab, in Edit Geometry rollout, click 
Attach button and click another sphere. Two sphere will be combined into one object.

4. Activate Polygon selection. Select several polygons like image below, and delete them.

5. Change to Vertex selection. In Front and Left viewport, move vertices position. Tips: In Front viewport, you can select a loop of 
vertices and scale them along horizontal axis using Select and Non-Uniform Scale tool. Use image below for reference.
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6. Now, choose Border selection. Select two borders like image below. To select more than one border, hold Ctrl while selecting. In 
Edit Borders rollout, click Bridge to fill gap with new polygons.

7. This conclude first part of Po modeling process. Next, you will modify head area.

In Part 1 tutorial, you have created Po's basic body shape. Next, you will modify Po's head to create eyes, ears, and nose. You will 
use several tools like Bevel, Extrude, Connect, and many more. Let's begin this tutorial section.

1. Continue previous tutorial. Activate Edge selection. In Left viewport, select all vertical edges in head area (look at image 
below). Then, in Edit Edges rollout, click Connect. Those edges will be divided.

Kung Fu Panda Modeling (1.2)
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2. Change selection to Vertex. Now, move vertices using image below for reference..

3. Let's move on. We are going to create a nose. Select two polygons in nose area. Hold Ctrl while selecting to select more than one 
polygons. In Edit Polygons rollout, click Bevel. Click and drag in viewport, to add slight Bevel to these polygons. Then, scale 
polygons using Select And Non-Uniform Scale along horizontal axis, to narrow the polygons. Then add another bevel..

4. Next, select several vertices in nose area (look at image below, make sure vertices in the back are not selected), and move them up 
and down to create better nose shape.
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5. Activate Polygon selection. In Front viewport, select half of object (right side). Then, delete those polygons. De-activate all 
sub-object selection. Next, apply Symmetry modifier. Make sure Mirror Axis=X and Flip is active.

6. Let's continue by creating eyes. In Modifier Stack, click plus (+) sign left of Editable Poly row, then highlight Vertex selection. 
In Front viewport, select one vertex in eye area. Then in Edit Vertices rollout, click Chamfer button. Click and drag in viewport to 
chamfer vertex..

7. Change to Edge selection. Select four edges from chamfering result. Then, in Edit Edges rollout, click Settings button right next 
to Extrude. A small dialog box will open. Enter Extrusion Height = -5 and Extrusion Base Width = 2. Click OK.
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8. Next, we are going to create an ear. Change to Polygon selection. In Left viewport, select one polygon like image below. Add bevel
to this polygon. Then, using Select and Non-Uniform Scale decrease polygon width. Next step, extrude this polygon twice. Modify 
vertices position to make ear shape.

9. Po's head is now finished.

Phew, in Part 1 tutorial, you have create basic body shape, and in Part 2 tutorial you sucessfully modify Po's head. Now, it's time to 
create Po's leg. You know, Po's leg is relatively smaller than original panda's. Moreover, if you compared to his belly.

1. Begin by selecting several polygons in Front viewport (look at image below). Delete them.

Kung Fu Panda Modeling (1.3)
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2. In Perspective viewport, rotate view until you can see bottom part of Po's model. Make sure you are still in Polygon selection. 
Activate 3D Snap Toggle. Then, in Edit Geometry rollout, click Create button. Click four times in order (1-4) in viewport to create 
new polygon. 3D Snap Toggle is activated to make you select vertex position precisely.

3. Change to Edge selection. Select two edges in newly created polygon (look at image below). Then use Connect to create new edge. 
Change selection to Vertex. Select vertices in newly created edge. In Front viewport, move them down. Then select one vertex only, and 
move it closer to another vertex (right image below)

4. Activate Border selection. Select border in leg area (look at left image below). Move border while holding Shift button in 
keyboard. Position vertices using blueprint as reference (look at middle image below). Select border again and Shift+drag to create 
more polygons for leg. This time, in Edit Geometry rollout, click Make Planar: Z button. The result is like right image below.
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5. Shift+drag border three more times again. Then modify vertices position, both in Front and Left viewport.

6. Let's continue to create foot. In Left viewport, select several polygons (left image below). Extrude them. Change to Vertex 
selection. Modify vertices position to create foot shape (right image below).

7. Next, change to Border selection. Select one border in the bottom of foot. Then, in Edit Borders rollout, click Cap button, to fill 
the hole with polygon..
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8. To finish modeling the foot, we need one more step. Activate Edge selection. Select all vertical edges in the bottom area of foot. 
In Edit Geometry rollout, click Slice Plane button. Slice plane will appear in viewport (yellow rectangle). Move slice plane down at 
the most bottom part of foot. Then click Slice button. When finished, turn off Slice Plane button.

9. Next, you are going to create arm and hand.

We have created basic body shape (Part 1), modeling a head (Part 2), and adding legs (Part 3). Now, we are going to create arm and 
hand.

1. Continue your previous lesson. In Left viewport, modify several vertices position (left image below). We need to do that before 
creating arm. When finished, activate Polygon selection. Select several polygons in area where you will create an arm.

Kung Fu Panda Modeling (1.4)
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2. Apply Extrude to this polygons. In Edit Geometry rollout, click Make Planar: X. Adjust size of polygons using Select and Uniform 
Scale. In Front viewport, move polygons if necessary to fit blueprint behind. Next, apply Extrude three more times again. You also 
need to position and scale polygons. When finished, don't deselect polygons but delete them. Finally de-activate all sub-object 
selection.

3. To create a hand, we are going to create from a box. Later, we will attach this hand object to Po model. Start by creating Box in 
Top viewport. Use parameters like image below. Move this box close to Po's arm.

4. Convert box into Editable Poly. Adjust several vertices position. Start from Top viewport. Use left image below fro reference. 
Next, in Front viewport move several vertices up.

5. Activate Polygon selection. Select three polygons in hand object. Extrude twice to create fingers. Then, select one polygon, and 
extrude to create thumb.

6. Select, 4 polygons in the wrist area of hand object. Delete them. De-activate all sub-object selection. Now, select Po model 
object. Go to Modify tab. Highlight Editable Poly row in Modifier Stack. In Edit Geometry rollout, click Attach button, then click 
hand object in viewport. After this, activate Border selection. Select two borders between hand and arm. In Edit Borders rollout, 
click Bridge to connect hand and arm.
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7. In Front viewport, compare model and blueprint. Fit arm and hand based on blueprint behind. You can scale or move vertices..

8. Your Kung Fu Panda model is almost finished. Next, we are going to create Po's pants.

After a quite long tutorial step, Part 1, Part 2, Part 3 and Part 4, we had a full model of Kung Fu Panda. Well, your Kung Fu Panda 
model is almost finish. We are only need to add pants for Kung Fu Panda model.

1. Continue your previous lesson. In Left viewport, modify several vertices position (left image below). Use blueprint behind for 
reference.

Kung Fu Panda Modeling (1.5)
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2. Change selection to Edge. Select vertical edges like image below. Use Connect to create horizontal edges. Activate Vertex selection 
and modify several vertices position to match blueprint..

3. Again activate Edge selection. Select vertical edges like image below. Click Settings button right next to Connect. In opened 
dialog box, enter Slide = -14. Click OK.

4. Select horizontal edges like image below. Tips: you can select one or two edges and then in Selection rollout click Loop. Click 
Settings button right next to Chamfer. In opened dialog box, makes sure Chamfer Amount=1. Then click OK. You have added small amount 
of chamfer.
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5. Activate Polygon selection. Select all polygons constructing pant. Make sure you select only polygons between chamfered edges. Then 
using Select and Uniform Tool, give slight enlargement..

6. Activate Edge selection. Select edges like image below. Apply Chamfer with Amount=1. Change selection to Polygon. Select polygons 
like middle image below (you need to select 6 polygons here). Then enlarge them a little bit. You will get a belt.

7. Next, select edges like image below (these edges separate pant and body). Give a slight amount of Chamfer, to make boundary between 
pants and body looks sharp, when we apply model with Turbosmooth.
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8. Do we forgetting something? Yup, a tail. De-activate all sub-object selection. Right click model and choose Convert to Editable 
Poly. Then, in Perspective viewport, rotate view until you can see back of Po model. Activate Vertex selection. Select one vertex in 
the middle of Po's buttocks. Use Chamfer. Change selection to Polygon. Select newly created polygon. Then use Bevel three times to 
create a tail. De-activate all sub-object selection.

9. To finish this model. Apply Turbosmooth modifer. Increase Iterations value if you want to get more smooth model.

10. Congrats, you have created Kung Fu Panda model. In the next tutorial, we are going to add texture.
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It's time to texture our little panda, after we created him in Kung Panda Modeling tutorial. We are going to use Unwrap UVW. If you 
are unfamiliar with Unwrap UVW, consider to look at our previous tutorial: Understanding Unwrap UVW and Unwrap UVW Texturing. It is 
quite hard to unwrap a complex model like human character or this panda. But, if you follow this detailed and step by step tutorial, 
you will be able to use techniques describe in this tutorial at any model. Let's unwrap!

1. First, open kung fu panda model you created earlier. Or you can download required 3D model here. Then, go to Modify tab. Remove 
Turbosmooth modifier. Then, apply Unwrap UVW modifier to model.

2. Next step is selecting model parts and name each of them. You need to do this in order to recall each object part later easily. In 
Modifier stack, click plus (+) sign left of Unwrap UVW modifer. Then highlight Face. Now, you are able to select faces. Select panda's 
head using Select Object tool. Don't select panda's ears.You can uncheck Ignore Backfacing for easy selection. If this option
inactive, you can select front and back faces altogether. Use Ctrl+click to select more faces. And Alt+click to reduce selection. 
After all faces in the head are selected, name these faces in Named Selection Set (located in top of the screen). For example type 
"head" and press Enter in keyboard

3. Next you need select anoother parts of model and name everyone of them. Use images below as references. In total, you should have 
16 named selection sets.

Kung Fu Panda Texturing (2.1)
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4. If you are happen to have wrong selection or name, click Edit Named Selection Sets button. In opened dialog box, you can highlight 
and delete the selection.

You have selected and named each part of panda model in Part 1 tutorial. Next step is to assign each object to its proper mapping 
type. For example head is suitable with spherical mapping type. Arm is suitable with cylindrical mapping type and so on.

1. Continue your previous lesson. Make sure Face selection is active in Unwrap UVW. In Named Selection Sets, choose "head". All faces 
in the head will be selected. In Map Parameters rollout, click Spherical. Next, clcik Align Z for mapping orientation. Don't forget to 
uncheck Normalize map. If this option is active, you will get deformed unwrap faces (3dsmax will force unwrapped faces to fit
rectangle)

2. Repeat procedure above with other part of model. Refer to table below. Note: some mapping need to be adjusted, like in "tail", "ear 
left" and "ear right". Just rotate Gizmo to fit selected faces. Watch image below for reference.

Named faces Mapping Type Orientation

body Spherical Align Z

head Spherical Align Z

arm left / arm right Cylindrical Align X

leg left / leg right Cylindrical Best Align

tail Cylindrival Best Align + Rotate Gizmo

sole left / sole right Planar Align Z

palm left / palm right Planar Align Z

briefs Spherical Align X

foot left / foot right Planar Best Align

ear left / ear right Cylindrical Best Align + Rotate Gizmo

Kung Fu Panda Texturing (2.2)
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ear left / ear right Cylindrical Best Align + Rotate Gizmo

3. In Parameters rollout, click Edit button. Edit UVWs window will open. Click Zoom Extents button in the right corner. Now, you can 
see all faces.

4. Select all faces. Scale down to make them smaller. Then, move them near blue rectangle. You need to scale all faces several times 
before they are small enough to fit the rectangle. To make you able to see blue rectangle clearly, click Options>Advanced Options. In 
opened window, uncheck Show grid and Tile Bitmap. You can also de-activate Show Map button.

5. Use Named Selection Sets again to select each model part. Move and arrange each them inside the rectangle. Just arrange so that you 
can see all object part clearly. Later, you'll have to to arrange again.
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In previous tutorial (Part 1 and Part 2), you have unwrapped faces. But you can't directly use this unwrapped faces for texturing. We 
need to fix some face position for easier texture drawing. There are several places we need to fix, like in head, body, briefs and 
leg.

1. In Edit UVWs window. Focus on head faces. Select several faces at left side (look at image below). In main menu, choose Tool>Break
(Shortcut Ctrl+B). Then, move detached faces to the right side. Change selection to Edge. Select several edges like image below. Use 
Ctrl+click to select more than one edge. You need to zoom in to select all edges. Then, choose Tools>Stitch Selected.Just click OK in 
opened dialog box. You'll have perfect symmetry head.

2. Next, we are going to fix body, briefs, and leg faces. Most people use Pelt Mapping when unwrapping legs. But in this tutorial I 
will only use standard unwrap uvw. Pelt Mapping will be discussed in another tutorial.

Select right side briefs faces. Use Break (Ctrl+B), and move each of them near the body. Look at image below fore reference. Use 
Rotate and Mirror Horizontal to each side of briefs.
Then, change selection to Edge. Select 2 edges in body. Choose Tools>Stich selected. In opened dialog box, uncheck Scale Clusters and 
then OK. Repeat the same proces with other side of briefs.

3. Change selection to Face. Select faces at left side of body. Break, move to the right and Stich them.

Kung Fu Panda Texturing (2.3)
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4. Now, leave body faces for a while. Let's modify legs faces first. Select both legs. Click Mirror Vertical, then Mirror Horizontal. 
Mirror Vertical is available when you click and hold Mirror Horizontal button.

5. Select several faces at right side of legs (look at image below). Break, move them to the left and Stitch

6. Now, select both legs faces. Use Scale Horizontal to reduce legs width. You can get Scale Horizontal button, if you click and hold 
Scale button. Then move each leg to its proper position near body (look at image below). Place legs as near as possible to body.

7. Change selection to Edge. Select several edges like image below. Then choose Tools>Stich Selected. This time uncheck Align clusters 
and Scale clusters. Click OK. Do stitching on one leg at a time. After stitching, you'll notice that in circled area there are unweld 
vertices. Change selection to Vertex. Go to Tools>Target Weld. Select one vertex in circled area, and move them to another vertex. We 
have finished fixing the faces position.
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8. Now, you can arrange model parts to fit rectangle area. Use scale if necessary. Make sure they are all inside the rectangle. Note: 
I use mirror to change arm orientation.

After we have created and fixed unwrapped faces in previous tutorials, we are ready to make texture template.

1. In Edit UVWs window, choose Tools>Render UVW Template. Enter texture size. For example I use 512x512 pixel. Then, click Render UV 
Template button. You can save texture template as bitmap image.

2. Open saved image in your image editing software, like Photoshop. Draw texture based on that image. Image below shows rough texture 
I created based on template.

Kung Fu Panda Texturing (2.4)

   Unfiled Notes Page 21    



3. Back to 3dsmax. Open Material Editor. There's one material applied to panda model. Remember, you applied this material while in 
modeling process. Select this material. Click Show Map button, to make applied material appear in viewport. In Blinn Basic Parameters, 
click small button right next to Diffuse. In Material/Map Browser choose bitmap, and then select texture image you have created 
before. When finished, close Material Editor.

4. Apply Turbosmooth and render your scene. Image below shows example of rendered result. Next step, I will show you how I create more 
realistic material.

This tutorial section will show you how to create more realistic texture for your Kung Fu Panda model. Original Kung Fu Panda Movie 
uses hair and fur, which did not explained here. Here, I just show you how to apply bitmap texture. Note: This tutorial is not a 
detailed step by step tutorial. I assume you are familiar with Photoshop. I just give a brief explanation how I create my texture.

First, prepare images for references. One from Kung Fu Panda Movie image, and the other is real life panda image.

Kung Fu Panda Texturing (2.5)
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1. Let's begin with panda's head. I crop half of real panda image and drag to the tempate. Scale that cropped image to fit the 
template. Then use Clone Stamp tool to create surrounding fur andface

2. I crop the eye from Kung Fu Panda Movie image, and drag into texture template. Then also crop some part in hand area of real panda 
image to add black fur. For left side of face, I just duplicate layer and use Flip Horizontal (Edit>Transform>Flip Horizontal). Next, 
use Clone Stamp tool to cover middle seam.

3. Next, draw dark color in ear area, to make smoother color transistion between head and ears. Then, fix eyes shape. Just use Clone 
Stamp tool with small brush size. Clone from dark fur area and white fur area.

4. For body, I crop several part of fur in real panda image. Resize and copy them several times to cover body. Then I use Clone stamp 
tool to make all fur copies blend well.
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5. The same technique applied with black fur. Cropping, copying and clone stamping. Note, add a little white fur with Clone stamp tool 
in armpit area, to make color transition between body and arm.

6. For belt, I just crop some belt image from Kung Fu Panda Movie image. Unfortunately I have curvy cropped belt image. To modify it, 
I use Edit>Transform>Warp. After that, resize and postion it in belt area. Sometimes I need to distort image (Edit>Transform>Distort). 
I repeat this process several times until I get full belt image.

7. For legs, same techniques applied here. I cropped from Kung Fu Pada Move image. Distort and copy paste to create desired looks

8. After that, I duplicate layer and flipped to create other side of body. Next is pants. I draw several pieces of solid color in one 
layer. Then under this layer, I create texture layer. I just randomize several texture with different texture size and rotation. Then, 
change top layer mode into Multiply. Sometime you can use Color mode too, depends on what color and texture you are using
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9. For stitch effect. I just use Line Tool a lot of times.

10. For another part of texture image, like in palm and foot, same technique applied here. I just use crop, copy from other image and 
sometimes drawing. Image below shows example of finished texture. Then, save texture and use as Diffuse map. You can add your own bump 
or specular map if you want.

11. Congrats you have finished Kung Fu Panda Texturing tutorial. Image below shows rendered result, applied with texture above. Next 
is Kung Fu Panda Skinning and Rigging tutorial.
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After you model and texture Po, character from Kung Fu Panda The Movie. Now, you can rig that panda model. Rigging is the process of 
placing skeleton system inside a mesh. There are 2 types of "skeleton" you can use in 3dsmax: Bones and Biped. Bones is usually used 
if you want to create bones manually. Otherwise, Biped is like a pre-built skeleton system. It's quick and fast to use. This tutorial 
will show you how to apply Biped to our Kung Fu Panda Model!

1. First, open textured kung fu panda model you created earlier. Or you can download required 3D model here. Select model, go to 
Display tab and Freeze this model. You need to freeze this model, so you can't accidentally select this model.

2. Next step is creating Biped. Go to Create>Systems. Click Biped button. Then, click and drag in Front viewport to create Biped. 
Biped systems consist of several linked "bones". Each "bones" is called "biped". After you created Biped, in Structure rollout, modify 
Biped structure to fit model requirement. Look at image below for reference.

Kung Fu Panda Skinning And Rigging (3.1)
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3. Next, you need to position Biped inside the model. Make sure Bip01 in Biped is selected and go to Motion tab. Then in Biped 
rollout, click Figure mode. This mode allows you to modify Biped structure and shape. Position Bip01 in the middle of model (look at 
image below for reference). Because Bip01 is the parent of all biped, all other biped are also moved.

4. Next, you need to modify each biped shape and position. Using Select and Non Uniform Tool strecth biped shape to fit the model. 
Also you need to rotate several biped arm.

5. Modify each biped shape. It's so simple, just use Select and Non-Uniform Scale in Front and Left viewport. You don't need to modify 
all biped. Just modify one side of model (left or right side).
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6. Special note: When you modify biped for fingers, extend biped farther than finger mesh. This is the trick so that you don't need 
tweaking in skinning process later.

7. Next, we are going to copy-paste biped shape position to other side. Double click one of shoulder biped. The rest of arm and finger 
biped will be selected. Open Copy/Paste rollout. Click New Collection button to name the selection, then click Copy Posture button. 
Finally, click Paste Posture Opposite to paste to the other side.

8. Using the same process like above, copy-paste leg posture. When finished, de-activate Figure mode and unfreeze the model..

Kung Fu Panda Skinning And Rigging (3.2)
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After we add Biped to model in Part 1 tutorial, next we are going to go into skinning process. Skinning is required to make skeleton 
system works by deforming the mesh. In 3dsmax, you can use Skin or Physique modifier to skin a model. In this tutorial, you will use 
Physique modifier to skin Kung Fu Panda Model. Physique is faster to use, if you use Biped for skeleton system.

1. This process is not necessary, but can help you to see biped inside model in Perspective viewport (Smooth and Highlight display). 
Select model, right click and choose Properties. Activate See-Through and click OK.

2. While model is still selected, apply Physique modifier to object. In Modifier Stack, position Physique modifier below Turbosmooth 
modifier. In Physique rollout, click Attach to Node button. Then click Bip01 in viewport. If you have difficulties in selecting Bip01. 
You can press H in keyboard. Highlight Bip01, and click Pick button. A new window will open. Click Initialize button. Now, your model 
is skinned.

3. Try to select one of biped. Rotate, watch the mesh also deformed. Click Undo (Ctrl+Z) to reset biped position.

Kung Fu Panda Skinning And Rigging (3.2)

Skinning process is not finished yet. We need to check whether model is deformed in the way we want. If not, we need to modify several
Physique attributes. Most of the time, this adjusting process is quite complicated. This tutorial will show you only the basic. But, I 
believe it's quite enough to create nice animation.

1. First, try to select one of upper arm biped. Rotate. Notice that some part of arm is not deformed along arm movement. Click Undo 
(Ctrl+Z) to reset biped position..

Kung Fu Panda Skinning And Rigging (3.3)
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2. Before you begin adjusting, you may want to hide biped in viewport. Sometimes it's hard to see clearly in viewport when biped is 
visible. Go to Modify tab. Highlight Physique modifier in Modifier Stack. In Physique Level of Detail rollout, check Hide Attached 
Nodes. Biped will be invisible. If you want to display Biped again, just uncheck this option. Whithout Biped visible in the screen, 
you can see only biped links (orange lines)

3.In Modifier Stack, click plus (+) sign at left of Physique modifier. Then, select Envelope. Biped link will turn yellow. Select
biped link at the upper arm. You will see red and grey circle. Those circles are called Envelope, which define area influenced by 
certain biped. Envelope has 2 areas, inner and outer. Biped influence in inner area is higher than outer area. Notice that, enveloped 
in upper arm is not covering all desired area. You can fix this by enlarging envelope. In Blending Envelopes rollout, focus on 
Envelope Parameters. Make sure Both is selected. Increase Radial Scale to 2.23. Both inner and outer envelope will be enlarged. After 
that, in Edit Commands click Copy button

4. You need to apply Envelope changes to the other side of arm. You can modify it manually. But, remember that you clicked Copy button 
before. Now, select other upper arm link and click Paste button. Both arm is now fix. You can de-activate Envvelope selection. Un-hide 
Attached Nodes to display all biped objects. Ttry to rotate upper arm biped to check.

5. Now try to rotate upper leg biped. Notice that, mesh in other legs is also deform. To fix this, just go to Envelope selection again
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5. Now try to rotate upper leg biped. Notice that, mesh in other legs is also deform. To fix this, just go to Envelope selection again

6. Select biped link in lower leg. First, make sure Both option is active. Decrease Radial Scale to 0.68. And then activate Outer
option, then decrease Radial Scale to 1. Copy-paste envelope to the other side of lower leg

7. If you rotate upper leg biped, you will notice that belt area is also deform. To fix this, go to Envelope selection.

8. Select biped link in pelvis area. With Both option active, decrease Radial Scale to 0.5. Copy-paste to the other side of pelvis.

9. The last one. Select biped link in head. In Active Blending, uncheck Deformable and check Rigid. Head should not deformed a lot in 
animation. When finished, de-activate Envelope selection. Skinning process is done. Actually we need more adjustment in skinning 
process, but that should be enough for now. I will try to write more tutorial about this subject in the future.
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This tutorial is the last of Kung Fu Panda tutorial series. After all hard work from modeling, texturing, rigging, and skinning, now 
ready for final lesson. You will create animation for our Kung Fu Panda model. This time you will use motion capture data to create 
animation. Motion capture (mocap) data is animation data stored from capturing real actor movement. We can re-use this animation data 
to any object, like our Kung Fu Panda model. Using mocap, you can create animation in a minute

1. Continue your previous lesson or download required 3dsmax file here. Select one of biped and go to Motion tab. In Biped rollout, 
click Load File button.

2. A window will open. In this window, you can select any motion capture data file you have. This motion capture data should have BIP 
extension. You can use BIP file available in your 3dsmax CD/DVD. Usually they are located in Samples/Motion folder or you can look for 
free motion capture data available in the net, for example here's a blog providing free mocap data

3. After you load BIP file, your model will use the animation movement stored in that file. Image below shows Kung Fu Panda doing some 
backflip kick.

Kung Fu Panda Animation (4.1)
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http://www.escalight.com/tutorials/3dsmax-tutorials/images/stories/tutorials/3dsmax/kungfupanda/kungfupanda_rigging_part3_finish.zip
http://freemotionfiles.blogspot.com
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